summaryrefslogtreecommitdiff
path: root/dev-python/ipdb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
commitea8740cede74808fe1546789e18738612217bb97 (patch)
tree50a16d926ab0d05dd840e745118ff229fcaf0b78 /dev-python/ipdb
parent06bb974d894b86598af155dc76a6fbd76c4fa30c (diff)
gentoo auto-resync : 13:01:2023 - 23:50:08
Diffstat (limited to 'dev-python/ipdb')
-rw-r--r--dev-python/ipdb/Manifest3
-rw-r--r--dev-python/ipdb/files/ipdb-0.13.9-tomli.patch54
-rw-r--r--dev-python/ipdb/ipdb-0.13.9-r3.ebuild41
3 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/ipdb/Manifest b/dev-python/ipdb/Manifest
index c29af017da9e..06082ae70cfc 100644
--- a/dev-python/ipdb/Manifest
+++ b/dev-python/ipdb/Manifest
@@ -1,6 +1,3 @@
-AUX ipdb-0.13.9-tomli.patch 2404 BLAKE2B 28f1fa1b44632d40eefeebaf641f78a18a324e8af14679886767f4e6f5365efa3c4d622cca605c3a4e43f8046ab721525e479cecd7319b4a0970e17b95859c83 SHA512 95ead7e4cc19b85cd74f8e621982e3075400be3bab7616eaeb976b1f0a598ba68996398cbdd805442b0952cd30177d447914b45d98b5df4bb8a71da4d64c2447
DIST ipdb-0.13.11.tar.gz 16770 BLAKE2B 849bb91f9fd2d0443f7696aee5e2b1de87a284b410189a471be91175e792132e816abcace865b788454d59ddbf5bc443c98e6308d0453b7a7a81a580c3afd24e SHA512 c44e012db71aa543742f16bd737e1e18db3f060b65c8fa0eaa6ce7567f99f44b5aa09bfb44457c6e4d6fb1fac8d822ece580bc4036adbd612f4d50a82f0eba21
-DIST ipdb-0.13.9.tar.gz 16820 BLAKE2B d028fff2c4273fd4a57c3338093f0065868856b4f7b2b95aa0db3c2b1e7c5906fc17b5b55b79b3a3809465214bd91ac1891cefc1604ed866edaa2811380175f6 SHA512 da0ac6d8a7451e90cf433ab2a0d4e43fff76be03082da5cf31b83fdc56174fde7f0256009ad9a407d805c0bf12da5fa2f081e1aa0e0ce73ca648262acd385671
EBUILD ipdb-0.13.11.ebuild 779 BLAKE2B 3494ad786a3f3e4ab3632c00854c831cda212220a7c8729c9cf38691d03e1ff7cff299187663a5073b364f4cc3fdf7d001856d5490363d29d73e662622043b7d SHA512 58e12d4a5de1c1e155fe86f7c7cd321cd8db5f9c5fbf33d8f6d87b2c993ce0e1290047cc63419be308a8cb7fb03b2dd1a492831d7cb6540159d2bea8178e9a1d
-EBUILD ipdb-0.13.9-r3.ebuild 779 BLAKE2B 3c2806d5b38496e31d9dee34af7c24a4b4a8fc3ebb4cb06386171a9fbce9095fcf7245186f7bed96a8dbcb7d3311e1bd142f7ce36eed26d95e106c54d59400d9 SHA512 643e6d810deddb1c398f41ba958addb967e75739b6a19e61e3b747c19749097516adc3391c51959dd00b498823e226420b6912303480f113130da9f5751f8ee6
MISC metadata.xml 383 BLAKE2B a522c204a84dae59832affc3f15720cd2ce7138f49a95633b94eecbc6d2976fa93d3fd3839a92405ccb2190fb5675119ec74bb0b0bcf41e7278ba2f062dfeae0 SHA512 6c70e5dc9d9d050bbbab2165d5b46afedc49438b2faa9c57391104d9b1a881ab696b6dddb6ad9bc814d36a4e0dc6211d719dd0e6ea73fd211240eb5901401d02
diff --git a/dev-python/ipdb/files/ipdb-0.13.9-tomli.patch b/dev-python/ipdb/files/ipdb-0.13.9-tomli.patch
deleted file mode 100644
index 20eecdd8721c..000000000000
--- a/dev-python/ipdb/files/ipdb-0.13.9-tomli.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From bc06e22817f2644c6ecc838f60c93fbedb9e0016 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 12 Oct 2022 16:57:24 +0200
-Subject: [PATCH] Support tomllib/tomli in newer Python versions
-
-Support the built-in `tomllib` module from Python 3.11 and the modern
-TOML processing library `tomli` in newer versions of Python 3. The old
-`toml` package is unmaintained and does not implement TOML 1.0
-correctly.
----
- ipdb/__main__.py | 14 ++++++++++++--
- setup.py | 4 ++--
- 2 files changed, 14 insertions(+), 4 deletions(-)
-
-diff --git a/ipdb/__main__.py b/ipdb/__main__.py
-index ea2ae88..2c3f675 100644
---- a/ipdb/__main__.py
-+++ b/ipdb/__main__.py
-@@ -176,8 +176,18 @@ def get_config():
- read_func(f)
- # To use on pyproject.toml, put [tool.ipdb] section
- elif filepath.endswith('pyproject.toml'):
-- import toml
-- toml_file = toml.load(filepath)
-+ try:
-+ if sys.version_info >= (3, 11):
-+ import tomllib
-+ else:
-+ import tomli as tomllib
-+
-+ with open(filepath, "rb") as f:
-+ toml_file = tomllib.load(f)
-+ except ImportError:
-+ import toml
-+ toml_file = toml.load(filepath)
-+
- if "tool" in toml_file and "ipdb" in toml_file["tool"]:
- if not parser.has_section("ipdb"):
- parser.add_section("ipdb")
-diff --git a/setup.py b/setup.py
-index 6ce51c0..04f594c 100644
---- a/setup.py
-+++ b/setup.py
-@@ -64,8 +64,8 @@
- # FTR, `decorator` is also a dependency of Ipython.
- ':python_version == "3.4"': ['ipython >= 6.0.0, < 7.0.0', 'toml >= 0.10.2', 'decorator < 5.0.0'],
- ':python_version == "3.5"': ['ipython >= 7.0.0, < 7.10.0', 'toml >= 0.10.2', 'decorator'],
-- ':python_version == "3.6"': ['ipython >= 7.10.0, < 7.17.0', 'toml >= 0.10.2', 'decorator'],
-- ':python_version > "3.6"': ['ipython >= 7.17.0', 'toml >= 0.10.2', 'decorator'],
-+ ':python_version == "3.6"': ['ipython >= 7.10.0, < 7.17.0', 'tomli', 'decorator'],
-+ ':python_version > "3.6"': ['ipython >= 7.17.0', 'tomli', 'decorator'],
- },
- tests_require=[
- 'mock; python_version<"3"'
diff --git a/dev-python/ipdb/ipdb-0.13.9-r3.ebuild b/dev-python/ipdb/ipdb-0.13.9-r3.ebuild
deleted file mode 100644
index d180cac0d023..000000000000
--- a/dev-python/ipdb/ipdb-0.13.9-r3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="IPython-enabled pdb"
-HOMEPAGE="
- https://github.com/gotcha/ipdb/
- https://pypi.org/project/ipdb/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/ipython-7.17[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/tomli[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( AUTHORS HISTORY.txt README.rst )
-
-PATCHES=(
- "${FILESDIR}"/${P}-tomli.patch
-)
-
-distutils_enable_tests unittest
-
-pkg_postinst() {
- optfeature "pyproject.toml support" dev-python/tomli
-}