summaryrefslogtreecommitdiff
path: root/dev-python/ipcalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ipcalc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ipcalc')
-rw-r--r--dev-python/ipcalc/Manifest5
-rw-r--r--dev-python/ipcalc/ipcalc-1.1.3.ebuild16
-rw-r--r--dev-python/ipcalc/ipcalc-1.99.0.ebuild21
-rw-r--r--dev-python/ipcalc/metadata.xml19
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/ipcalc/Manifest b/dev-python/ipcalc/Manifest
new file mode 100644
index 000000000000..807f50c82008
--- /dev/null
+++ b/dev-python/ipcalc/Manifest
@@ -0,0 +1,5 @@
+DIST ipcalc-1.1.3.tar.gz 8099 BLAKE2B 27ffef8ca70db237c4d22a8ee1f91a167446e6135d70d7ca435222a52a0451557c8c60fca64655535679fdd231585a50b2322c3e5b87447f5699d1021d5201c0 SHA512 f852e93bfa4994e424a8aafc74a1e8ec9488d4c60085fbc53e0587abcf8fbfdc7a35d7a20e67cd4dbe0d8484c0e7bfb11b5fe3d6934f322dd818273e3d64c2c6
+DIST ipcalc-1.99.0.tar.gz 12120 BLAKE2B 43afe713c32eae9465e4baacbea24205e73cea989921a27e56fa2182108bac46e4c7f3376bacc5b891e441fc23f502ed4248121d27a565a0f28eca197ad5f9a6 SHA512 a7d9633fd464a0d5c5cdae9552edfe42a55906f5d378c676dba14552d4214590d88f32cb43cad14181d55ed3c3efd95a2fad1535ab7a8bc2bbb092b2bb4748cd
+EBUILD ipcalc-1.1.3.ebuild 347 BLAKE2B 729de03073368b081054aa7cc6f6f9937c2d71b05717fe849f1ecd99d3a760df7afcbde2bc09707cff1f6f3fb5452a77db6ca81f5a41e15893472f370da45ef7 SHA512 9a9d07370afb6110c099027a20fe6a7f2b97bb08ce80b338b0ddca8d1272729964b6a4cea7587cec0dbc7a7db67b7bdb4812e1c9912fa388e623b3f1462bb61b
+EBUILD ipcalc-1.99.0.ebuild 480 BLAKE2B 0e212bca97e53f885730d4b6f3c76caa1d2e86592c51dd34e278c882a0c5202bb3f7d8c0f76769c703e540ef92a3143fc91abc12756a42f7d5893f154222e2cb SHA512 befec7985331b121fc04dab03684f24fe8e1d8cd9c8ebc94b9460ba00fee97f77585f137e45b30700d659f0f5990cc2825c31c81b58283a2a17a160e626a2e67
+MISC metadata.xml 525 BLAKE2B 372a04ba496d2b0846cfae334056c96e6e32ea0b4a18c1c9c3b6f38803357e4727d6bb79d04b4c760dae53ca64e7d59ce43261e6209e832922a7a90aea5d27ef SHA512 32b6b0941abd8b1a9bc3fb81af8ff97baf7a0ea1e02a86a5b73da7bf34daaa09188622a82c019c7f89fc6c8635dc07d04692f0ba59f0dcb2cbbc54e1e0108808
diff --git a/dev-python/ipcalc/ipcalc-1.1.3.ebuild b/dev-python/ipcalc/ipcalc-1.1.3.ebuild
new file mode 100644
index 000000000000..bdd86bb3f6f8
--- /dev/null
+++ b/dev-python/ipcalc/ipcalc-1.1.3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="IP subnet calculator"
+HOMEPAGE="https://pypi.org/project/ipcalc/"
+SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE=""
diff --git a/dev-python/ipcalc/ipcalc-1.99.0.ebuild b/dev-python/ipcalc/ipcalc-1.99.0.ebuild
new file mode 100644
index 000000000000..499414f17784
--- /dev/null
+++ b/dev-python/ipcalc/ipcalc-1.99.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="IP subnet calculator"
+HOMEPAGE="https://pypi.org/project/ipcalc/"
+SRC_URI="https://github.com/tehmaze/${PN}/archive/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${P}"
diff --git a/dev-python/ipcalc/metadata.xml b/dev-python/ipcalc/metadata.xml
new file mode 100644
index 000000000000..8858b18db9ab
--- /dev/null
+++ b/dev-python/ipcalc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>geaaru@gmail.com</email>
+ <name>Geaaru</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ipcalc</remote-id>
+ </upstream>
+</pkgmetadata>