summaryrefslogtreecommitdiff
path: root/dev-python/ioflo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/ioflo
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/ioflo')
-rw-r--r--dev-python/ioflo/Manifest1
-rw-r--r--dev-python/ioflo/ioflo-2.0.2-r2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/ioflo/Manifest b/dev-python/ioflo/Manifest
index f1e924e49415..3080798b1a6c 100644
--- a/dev-python/ioflo/Manifest
+++ b/dev-python/ioflo/Manifest
@@ -4,4 +4,5 @@ AUX ioflo-2.0.2-python39.patch 3813 BLAKE2B a21f5829b5a2fd4200350949d66d4fd77f5b
AUX ioflo-2.0.2-tests.patch 1059 BLAKE2B a093cf0db0e00c4f06f0eeda76acee4515951e0dca1a77688e2cd4ccc33a3b10402228d76aa25f787cbfa8771d12f0613fe62e5fa38e09b6d8238870c2b25951 SHA512 5642963e6c29941c2803c6833d229b9fab62f60e7534fb6bfd7a101746eff1704dcfe3bdbbc72bfb466317562d995ede5a70a8ffc83ae9e76ab2d9c01bcab349
DIST ioflo-2.0.2.tar.gz 837382 BLAKE2B 1fe878c8a9a47a9be5083e392e15256f1a566433b4341e2ee234e84332bb72af0c426d04c77ccace33cfb05664745caaa63e910913c3d63bbb2e5d8360a1ec90 SHA512 7485924ce329889afb1c3e0555b54fdbfb11eafce48fb0ac15bacd229fea512c44fcc118bbc4368ebc7c770d62129ee6b895b982f73a269de7131ea37daac02b
EBUILD ioflo-2.0.2-r1.ebuild 963 BLAKE2B 9838b1c970433daeb79bb877f5ed72db9150249d0d5307a299ad969c35c880750d66fee3426dc4569c45afa3cca57bd51a49ddf77ee9dcf694af6f983272a7af SHA512 fb4eeb959d214349c17aa82c8c6a01e33c6f81a4d512c84c67e6d9d6de3f7ce590acaa70d00d1fbf6685c3a380972bd14aaf5c00430fab77c6d741e82f39ac6e
+EBUILD ioflo-2.0.2-r2.ebuild 961 BLAKE2B a38dc70591cdb50076baef144cb10400640c01095e0ed09d03ecb14d2ee6559cd73d702be20f82a8d64f1670fa634d3e7776db1fb38263d5d2f29bf70830de7c SHA512 145e79dab3608897d4bc2f05107b0175fd3b9490e4c7ca12ba66aad9536793f2ea6f0a749b85d36dbd1895af223c6ee41c2d3bbd2b3ae94423fb2a9684e584e2
MISC metadata.xml 494 BLAKE2B dc398c0ee508c0c1cf9ee17712efcbf7f994ed053416da6bdd236fe80402b80ce251272824bebbdcc7ea79cf98b6b5dd812de11fca55eb625bf19e5cf93228e3 SHA512 7364c6b7a37dd8ed762fc7d609e71ff93cd3321f6f94f88d795bd0a3082749571644cbdfd3c9d63a916249122fdfb47ff5377907159782ddf5744c5ea4a13f39
diff --git a/dev-python/ioflo/ioflo-2.0.2-r2.ebuild b/dev-python/ioflo/ioflo-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..450633f76998
--- /dev/null
+++ b/dev-python/ioflo/ioflo-2.0.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-lang/python-3.7.4' python3_7)
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest-salt-factories[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/ioflo-1.7.8-network-test.patch"
+ "${FILESDIR}/ioflo-2.0.2-python39.patch"
+ "${FILESDIR}/ioflo-2.0.2-tests.patch"
+ "${FILESDIR}/ioflo-2.0.2-py310.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's:"setuptools_git[^"]*",::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}