summaryrefslogtreecommitdiff
path: root/dev-python/ioflo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ioflo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ioflo')
-rw-r--r--dev-python/ioflo/Manifest5
-rw-r--r--dev-python/ioflo/ioflo-1.5.0.ebuild18
-rw-r--r--dev-python/ioflo/ioflo-1.7.4.ebuild19
-rw-r--r--dev-python/ioflo/metadata.xml15
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/ioflo/Manifest b/dev-python/ioflo/Manifest
new file mode 100644
index 000000000000..753d1b3bc7d1
--- /dev/null
+++ b/dev-python/ioflo/Manifest
@@ -0,0 +1,5 @@
+DIST ioflo-1.5.0.tar.gz 765559 BLAKE2B 56b3e26b6155cf8fbc5f159909d3a82a6c9b47251c799e4f6ef300015d0b55f54882e26534314fc3c04e20248aaedc9a35a1ff1c574cfb5dd3d1f7aa887340da SHA512 114dd5ab3ab5bbe66be7e639c2018256ff1c8ab18ba73931733dbe23c8f65631fd630f278b0a186303e288a6f49cd6df224dda462973cc258b3d07114e70c991
+DIST ioflo-1.7.4.tar.gz 834916 BLAKE2B 241026d18f8caa6acc09f312a285a3f824128d6018ab19a8704296f916514f7795b8f2359dcf46c04d01735140a75c980458d5589d72de59fc73f13c59b50b14 SHA512 415b43b66c1be479e8ba4fc993f180418f95f1ae0d16ff8c496476da7a04f6caa0f918a064c60034cd926f4f49c1112946b911b57339a76ee5b0d2564ade224f
+EBUILD ioflo-1.5.0.ebuild 487 BLAKE2B 809b8f7fc482a9ced7f0148e79fc8dcfd58f41d747fafa12248ba82febc237a2a1d8aa77468fc279d4e55d98b4694d5d47b7e9a6957635fb2fe19aaa1bf06cee SHA512 44c4dd772945ac479e121b205989b988fd81ba2d3548636770e47a17a279490b042112c9790cdc7820a1b96ea95e695d1bd114e7451b6b0966bff2bb1889146d
+EBUILD ioflo-1.7.4.ebuild 540 BLAKE2B 39d6075c283baac615918de5ce84a398603f990dfcf1d6f8cb09cdd107054153af890ff67ecf11819df6e08587cb677842fe4e3aa8f7511d50b70fd5c745deab SHA512 d7dbbe21d04f590dbbd2a4428fbc432e78c3ae4c7af1d94101ba10179d275e91784cd79364afd2a3550e60244b3cc560a9a73c4a9baaa441ea8f9f3efb71796d
+MISC metadata.xml 442 BLAKE2B 26c46608c3b6b62389b07f8a089a0dd6ba91701b3e18758d39a82980a16ce7fd03f4a080e15dc37006919904764a4fe9ce31183d31423e2c177c7c154d2cdc0a SHA512 8d6a727c351749f21566b4085b2355611b40e7a962e99d1a0e52d19d96f3d64db66c17ef01d08b82b4031bcdc637ae0a074423fd1eb92323334d6ee36d004742
diff --git a/dev-python/ioflo/ioflo-1.5.0.ebuild b/dev-python/ioflo/ioflo-1.5.0.ebuild
new file mode 100644
index 000000000000..0c230f0e0c51
--- /dev/null
+++ b/dev-python/ioflo/ioflo-1.5.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/ioflo/ioflo-1.7.4.ebuild b/dev-python/ioflo/ioflo-1.7.4.ebuild
new file mode 100644
index 000000000000..6bc509dcef22
--- /dev/null
+++ b/dev-python/ioflo/ioflo-1.7.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-git-1.1[${PYTHON_USEDEP}]"
diff --git a/dev-python/ioflo/metadata.xml b/dev-python/ioflo/metadata.xml
new file mode 100644
index 000000000000..3273120e4e7c
--- /dev/null
+++ b/dev-python/ioflo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ioflo/ioflo</remote-id>
+ </upstream>
+</pkgmetadata>