summaryrefslogtreecommitdiff
path: root/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/iocapture/iocapture-0.1.2-r2.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/iocapture/iocapture-0.1.2-r2.ebuild')
-rw-r--r--dev-python/iocapture/iocapture-0.1.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/iocapture/iocapture-0.1.2-r2.ebuild b/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..3ad57635e00d
--- /dev/null
+++ b/dev-python/iocapture/iocapture-0.1.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture stdout, stderr easily"
+HOMEPAGE="https://pypi.org/project/iocapture/"
+SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+LICENSE="MIT"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}