summaryrefslogtreecommitdiff
path: root/dev-python/intelhex/intelhex-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/intelhex/intelhex-2.3.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/intelhex/intelhex-2.3.0.ebuild')
-rw-r--r--dev-python/intelhex/intelhex-2.3.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/intelhex/intelhex-2.3.0.ebuild b/dev-python/intelhex/intelhex-2.3.0.ebuild
new file mode 100644
index 000000000000..083de2fbfcf8
--- /dev/null
+++ b/dev-python/intelhex/intelhex-2.3.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for Intel HEX files manipulations"
+HOMEPAGE="https://pypi.org/project/IntelHex/ https://github.com/python-intelhex/intelhex"
+SRC_URI="mirror://pypi/I/IntelHex/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+distutils_enable_tests setup.py