summaryrefslogtreecommitdiff
path: root/dev-python/ini2toml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
commitcd0d9000770337b445051f1852fe3971ceb7a6e2 (patch)
tree49c82dbb14c2d960e04e7482bdefe6ed2d53a173 /dev-python/ini2toml
parent12c505f7fcc9ddc89e96ed178df05aceec162d92 (diff)
gentoo auto-resync : 18:03:2023 - 18:31:42
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest2
-rw-r--r--dev-python/ini2toml/ini2toml-0.12.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index 44fff4c42e09..ba6723995d25 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1,3 +1,5 @@
DIST ini2toml-0.11.3.gh.tar.gz 94011 BLAKE2B c827b4030f7c80fa749cdccc170dfced7c869836c90e3350e486be94a30541983c79161e6fb4b007258a692abd62e8b724ac758f6c952b0c7b820e9b5679706d SHA512 f1331bc47a2d4593788de9d8b1fdbc2231ac22524aaf3a83695c810e0dcbdce4bb46c48363ea150a583e4b24264d7a25f85ece737b31fa0ec0b8a6a2e098a9d5
+DIST ini2toml-0.12.tar.gz 101098 BLAKE2B 8e44600718318ce9c2ebaa5205864c1ca6ce87852a59496801578f32e223b9283d2f724acf004136743f87c8a081e58fd1176abe85288f8c463fc2520f708633 SHA512 c324a65fa20af880f2731b740dbf041ef7673d7ab817a9ee1947bf781d39bc000fcd8a725a546fc6af0dbecd0ec0534b2f9b83f3d8ab4afc0239d94acca06df5
EBUILD ini2toml-0.11.3.ebuild 1224 BLAKE2B 002768777b3f62cf4963122f7735126542f7221bde505757eacdb1051439c605d36239f7b91ec2942481bde6dccea7b46058cbe8b841218c1c3988bd98d60737 SHA512 2757bec71bff12f231d89af0db011aef75ccc3732107eca23d32691fb863a8abcee58cc3543d7184231df46fed49f32bcde68b58ed525a61c7b23e0cc2e185a6
+EBUILD ini2toml-0.12.ebuild 1097 BLAKE2B f0b7a85372442ca67da690664ed79e88eec85447e6bc82e3e6124f1f93bf427340d58b1bd4f7954ba33359abf3ce15904e61ff80264bf04fac08c480cc29890b SHA512 f9e36d73f1790ae2f4bdbb69d0e057de2a4f840849ebfae58832dd2c869fa5ab115530b68041a8ee0b84bcdc2e58b39a358ff564efa18724e0d4bd0d01390b8e
MISC metadata.xml 374 BLAKE2B d1d096c2db4d1975e07553486be8e1ef66a63338b6a6617f71131565b80f612b9d50ca7c039d0b37b02eec56421231f52833390eb8536de44d4edd7c90d307f2 SHA512 21a272e9c3a7eb3e0950358f8ffb90b961ff0e39073519ed0b36660dfae91b24f8e09e3b89a20dbeadba45d995eea4bb89d484acc04a7251dfb9f33603bef998
diff --git a/dev-python/ini2toml/ini2toml-0.12.ebuild b/dev-python/ini2toml/ini2toml-0.12.ebuild
new file mode 100644
index 000000000000..b796d712c588
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}