summaryrefslogtreecommitdiff
path: root/dev-python/ini2toml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 08:38:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 08:38:03 +0100
commit9c572b23bc56215e9d24d375ddd293982c07dc08 (patch)
tree7db2215a276dccb1c70adc0dacf0eac994458517 /dev-python/ini2toml
parentd498c2e6fb30b46f7db6e726a0edc1ba2b9d52b6 (diff)
gentoo auto-resync : 24:10:2023 - 08:38:03
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest2
-rw-r--r--dev-python/ini2toml/ini2toml-0.13.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index d21f7c5d798a..ed17ef536428 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1,3 +1,5 @@
DIST ini2toml-0.12.tar.gz 101098 BLAKE2B 8e44600718318ce9c2ebaa5205864c1ca6ce87852a59496801578f32e223b9283d2f724acf004136743f87c8a081e58fd1176abe85288f8c463fc2520f708633 SHA512 c324a65fa20af880f2731b740dbf041ef7673d7ab817a9ee1947bf781d39bc000fcd8a725a546fc6af0dbecd0ec0534b2f9b83f3d8ab4afc0239d94acca06df5
+DIST ini2toml-0.13.tar.gz 102729 BLAKE2B 27094e0f329ce5d0da3ca1793b5b92e97eba5068225c55fcc9e0c61ead607967b8718976bfa13f76638c1b2bd8ee2a532b8eaf2023895f2ffdeacacd072fff9c SHA512 9700affeeb0434699e708fbeffb34e68f54882d7c5ada25cbdcdf47fed70bf8b5e8ff46503c19aa135079bc8770bdc48e991212b07b6409adf57d197a5ed998e
EBUILD ini2toml-0.12.ebuild 1090 BLAKE2B 9e14ab1cf2059dd8cba9e37aca0636b9f1b2abc84a4ed89b5dbb8fcdd5511930da4132aa29e04d9b7e77622e86afdb7d5c65626e6942661437a7fd8a4d370720 SHA512 f32a15f60d503cb9fea072454f49d932189da46f9f89b13fe34986518712de809df5dd7d1e3457b217c33d790883ccc18a1eaf9b79770f3e63e8d959128df0a4
+EBUILD ini2toml-0.13.ebuild 1146 BLAKE2B 33c162ea224c21f97d3b55db107b1945ca34bf030d70f1f4cea85c09a96fb104dfa99efd42c43a7f03db2464636ff7406d4899680edb1511821171619168cc3e SHA512 f49ec683bcf9854de1fdc4abf254d0c351ce64d722d24bce44c021cf8be60f5a0d285d326f96ed6a62801dde6cbe54a1169bd9798b2e546407bf40634fda1faa
MISC metadata.xml 374 BLAKE2B d1d096c2db4d1975e07553486be8e1ef66a63338b6a6617f71131565b80f612b9d50ca7c039d0b37b02eec56421231f52833390eb8536de44d4edd7c90d307f2 SHA512 21a272e9c3a7eb3e0950358f8ffb90b961ff0e39073519ed0b36660dfae91b24f8e09e3b89a20dbeadba45d995eea4bb89d484acc04a7251dfb9f33603bef998
diff --git a/dev-python/ini2toml/ini2toml-0.13.ebuild b/dev-python/ini2toml/ini2toml-0.13.ebuild
new file mode 100644
index 000000000000..737ed94cbe5b
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-59.6[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}