summaryrefslogtreecommitdiff
path: root/dev-python/ini2toml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 17:24:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 17:24:07 +0100
commit800c4c398cad9dd837da33062e71ccc84114fe05 (patch)
tree9016107a696d96ddfaea5f7fa6d55eadc54d4987 /dev-python/ini2toml
parentc17e7d2a8cc12551a02d28209cd2edbf078d5675 (diff)
gentoo auto-resync : 20:09:2022 - 17:24:07
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest1
-rw-r--r--dev-python/ini2toml/ini2toml-0.11.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index c4cd5ecc8b15..666b26bc5d74 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1,4 +1,3 @@
DIST ini2toml-0.11.gh.tar.gz 93696 BLAKE2B 0fb52b346065421049fd377a62de4189a6d261ad12c00679c97568a0e7b7f8fc7bf1aae2196b8fc70489d547c0ce9be1347336d25769c7fb383f9fec4d4aa205 SHA512 7329fd3ba31567638fffce22f2370c2055503bd4abc3d7dab30b1828eb54204d31036753efddfab52e79703ce7583f6070e1207c95345096c0751c2d429fd6ea
EBUILD ini2toml-0.11-r1.ebuild 1205 BLAKE2B f2d1145c01f54be5bc29bb0b6c6f94093009b5357b8974a2bb5dd6b428f85d9e9654adfb07f8a3bac39a1173e427f53a45cbd49cb57cffc8e61336090835ae6c SHA512 d23f40a4fcbbe3d60eaa274fe9f529f6f0d15ec484a4caf2f8629fc1bc2fd1ed21cfbb19187e925fdb0281a6b3cf7a7aa1d212c4bc57b113707df54a8a8f0959
-EBUILD ini2toml-0.11.ebuild 1711 BLAKE2B 1837c2f2e3af0b878a7e3c0a58aec8139ad2582048ffa89d5b80720c700bf53f8180db7221678209bb3aa1de89f938416df22822a4a37316281ad549bdc8525b SHA512 2bb9474cbdbe15c9d2c9ec4f59fb2661171b54d27a40722996f22b5c5a2886c0676b2ae4a8a1ffb65cc8e7c56236a9d2a8c8cbb3fb0714ec5c9a0e47b6572127
MISC metadata.xml 374 BLAKE2B d1d096c2db4d1975e07553486be8e1ef66a63338b6a6617f71131565b80f612b9d50ca7c039d0b37b02eec56421231f52833390eb8536de44d4edd7c90d307f2 SHA512 21a272e9c3a7eb3e0950358f8ffb90b961ff0e39073519ed0b36660dfae91b24f8e09e3b89a20dbeadba45d995eea4bb89d484acc04a7251dfb9f33603bef998
diff --git a/dev-python/ini2toml/ini2toml-0.11.ebuild b/dev-python/ini2toml/ini2toml-0.11.ebuild
deleted file mode 100644
index 16baf50290cb..000000000000
--- a/dev-python/ini2toml/ini2toml-0.11.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
-HOMEPAGE="
- https://pypi.org/project/ini2toml/
- https://github.com/abravalheri/ini2toml/
-"
-SRC_URI="
- https://github.com/abravalheri/ini2toml/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
- >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/tomli[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # pyproject_fmt is not packaged
- tests/test_cli.py::test_auto_formatting
-
- # fails on whitespace/comments/formatting
- tests/test_translator.py::test_simple_example
- tests/test_translator.py::test_parser_opts
- tests/plugins/test_setuptools_pep621.py::test_move_entry_points_and_apply_value_processing
- tests/plugins/test_setuptools_pep621.py::test_split_subtables
- tests/plugins/test_setuptools_pep621.py::test_entrypoints_and_split_subtables
- tests/plugins/test_setuptools_pep621.py::test_handle_dynamic
-)
-
-EPYTEST_IGNORE=(
- # configupdater is not packaged
- tests/test_examples.py
- tests/test_transformations.py
- tests/drivers/test_configupdater.py
-)
-
-src_prepare() {
- sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
- distutils-r1_src_prepare
-}