summaryrefslogtreecommitdiff
path: root/dev-python/ini2toml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 07:12:05 +0000
commit14a74a5f982f25582974c2ee235027a041aec36d (patch)
treedc57c37e535d9d67af9a5034c4748ec3698923b9 /dev-python/ini2toml
parentb1b0997aac1e7f68389ed3e0f95d3ea9d92277e2 (diff)
gentoo auto-resync : 25:11:2022 - 07:12:04
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest2
-rw-r--r--dev-python/ini2toml/ini2toml-0.11.3.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index 2f1e7c8bfc73..6b7399c46351 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1,5 +1,7 @@
DIST ini2toml-0.11.1.gh.tar.gz 93986 BLAKE2B ec5cd963626b5391663b782ba8c32996f6d172e034eb1f9476da0336ebd3dc5d2244fe72a039bb121182e85df798da37dfc391a52808e9e8a9e84d3c5e1889a0 SHA512 5229072e5ebaffb1c2efd16f58f72c562fd1ca73d3ce46dccc80672085301f9d35460796f8ac4118ea37f970e45d4e4d4efd3da8e4a88c6a696f1e8b644cf1cd
+DIST ini2toml-0.11.3.gh.tar.gz 94011 BLAKE2B c827b4030f7c80fa749cdccc170dfced7c869836c90e3350e486be94a30541983c79161e6fb4b007258a692abd62e8b724ac758f6c952b0c7b820e9b5679706d SHA512 f1331bc47a2d4593788de9d8b1fdbc2231ac22524aaf3a83695c810e0dcbdce4bb46c48363ea150a583e4b24264d7a25f85ece737b31fa0ec0b8a6a2e098a9d5
DIST ini2toml-0.11.gh.tar.gz 93696 BLAKE2B 0fb52b346065421049fd377a62de4189a6d261ad12c00679c97568a0e7b7f8fc7bf1aae2196b8fc70489d547c0ce9be1347336d25769c7fb383f9fec4d4aa205 SHA512 7329fd3ba31567638fffce22f2370c2055503bd4abc3d7dab30b1828eb54204d31036753efddfab52e79703ce7583f6070e1207c95345096c0751c2d429fd6ea
EBUILD ini2toml-0.11-r1.ebuild 1211 BLAKE2B fac15dff7abc67c1929413821ac07b45d7bfe53e5931529b820e03258978daf49218850eb4271904c4ab3c15c150aa443e392dd116eff828bc62fcb76a469362 SHA512 98c46e72e786d2e01b3ccaea2f2fe466810036f61223526c4b2a5b213a521d6cf7e56a1ae394b74dbebaf6156f1ae8f6c5487bdc82778af67d02c8e4f4d6d3d8
EBUILD ini2toml-0.11.1.ebuild 1219 BLAKE2B 68c5b7edeaf6fd184a10f2b0d92f63468501be7edd78dbdd6ad11b27a11bebaffc4db26a9c24b5972f5b554c4752fd8182c1634dec8c5a391c6e4942799111d6 SHA512 0a932992810d33430f58a28e5bcd60071656fcef067575930f63171f9d9affafc9a0a4348f577fd44863ca13e12fc3b94668110d4049b8f8e44e129f4b7ded67
+EBUILD ini2toml-0.11.3.ebuild 1227 BLAKE2B baac72076f8146426cd9bbca231dd504e1b25c8e15b52db40845b74df8b124de94ac2ce0d6f35f8bebf72639c8332cf98b6ce4a8b1e544e304d9d400e7f4a2ce SHA512 4ca999974a2913dd537d0bc3fab53ec1691fdcca643ebd0208bcddc61efea9a2070b0ec55ce5e098fef33078dbb4c320fe01dc3c5bca5e102a866542965c3928
MISC metadata.xml 374 BLAKE2B d1d096c2db4d1975e07553486be8e1ef66a63338b6a6617f71131565b80f612b9d50ca7c039d0b37b02eec56421231f52833390eb8536de44d4edd7c90d307f2 SHA512 21a272e9c3a7eb3e0950358f8ffb90b961ff0e39073519ed0b36660dfae91b24f8e09e3b89a20dbeadba45d995eea4bb89d484acc04a7251dfb9f33603bef998
diff --git a/dev-python/ini2toml/ini2toml-0.11.3.ebuild b/dev-python/ini2toml/ini2toml-0.11.3.ebuild
new file mode 100644
index 000000000000..e330aeb75a3d
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.11.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+SRC_URI="
+ https://github.com/abravalheri/ini2toml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}