summaryrefslogtreecommitdiff
path: root/dev-python/inflect/inflect-5.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 13:45:36 +0100
commit29607d91fb1bf1c4456a0b90601ee172ea769283 (patch)
tree71a1c87ff8b0a522d0f8243a4f064f8f9b5d94e4 /dev-python/inflect/inflect-5.6.2.ebuild
parent22b96ae0ceb12f57b30fc2577770f565506bbac8 (diff)
gentoo auto-resync : 16:07:2022 - 13:45:35
Diffstat (limited to 'dev-python/inflect/inflect-5.6.2.ebuild')
-rw-r--r--dev-python/inflect/inflect-5.6.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/inflect/inflect-5.6.2.ebuild b/dev-python/inflect/inflect-5.6.2.ebuild
new file mode 100644
index 000000000000..ea873a0cffa0
--- /dev/null
+++ b/dev-python/inflect/inflect-5.6.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest