summaryrefslogtreecommitdiff
path: root/dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild')
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild
deleted file mode 100644
index f2cf3667d4c1..000000000000
--- a/dev-python/indexed_gzip/indexed_gzip-1.6.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Fast random access of gzip files in Python"
-HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
-SRC_URI="https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sys-libs/zlib:="
-DEPEND=${RDEPEND}
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )
- "
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:--cov=indexed_gzip::' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-src_compile() {
- if use test; then
- export INDEXED_GZIP_TESTING=1
- fi
- distutils-r1_src_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib/indexed_gzip/tests || die
- epytest
-}