summaryrefslogtreecommitdiff
path: root/dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild')
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild
new file mode 100644
index 000000000000..45265669e01d
--- /dev/null
+++ b/dev-python/indexed-gzip/indexed-gzip-1.8.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="
+ https://pypi.org/project/indexed-gzip/
+ https://github.com/pauldmccarthy/indexed_gzip/
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_compile() {
+ # This actually enables line tracing, so it fits USE=debug more.
+ if use debug; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ # Fix implicit dependency on numpy that is used to build test
+ # extensions.
+ if ! use test; then
+ local -x PYTHONPATH="${T}:${PYTHONPATH}"
+ cat >> "${T}"/numpy.py <<-EOF || die
+ raise ImportError("I am not here!")
+ EOF
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
+ epytest
+ # temporary files and test extensions
+ # (to achieve equivalence with USE=-test)
+ rm ctest*.{c,gz,so,tmp} || die
+}