summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/importlib_resources
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 2d4b7fb84952..12b014100d6c 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,4 +1,5 @@
AUX importlib_resources-1.0.2-skip-wheel.patch 305 BLAKE2B 741e9825c64a88696603d31d9b749fcd3756bcb44755730b12d22afddf911d178365904885d2323aa5b331f44f20b6e3306ad03adb60794c6c83cd1b0795c902 SHA512 6e3f90b1544c6de97768aaae708d1bc93494dcdf1cf10d59e48b55406c9a6c9bc9eb5f5c0d034bcff99eae5274c1f1a467a9bd2a4292f0eadf0686286b879f77
DIST importlib_resources-1.0.2.tar.gz 23602 BLAKE2B 24c27b45ec56d3838b039baf2ebc1e0c5ec582d5cfdeb5cf26587255bf8b32aa1fcf43802cabca3b82b3ddec8cdf2616d10489c3c1aca77c9fa91af1f25ef9e7 SHA512 50bfc5130a2c9c9354efef1cd7132e805ed0f13467ba67172f83e11d907212bef3957aeef51fd904b73996c8280008d99c918637956a470448dfd67ef4807f82
EBUILD importlib_resources-1.0.2-r1.ebuild 1254 BLAKE2B 295ecf68ea748305ab37ec0b1aa5703ebc9c62728b6a6053cf82561b44d09574d7e5c257b134fa33c7ce950a9f2b83a99bb0c6f21cc56396c97d1f1c8c085c47 SHA512 98e853072c15ebe11dd3091cc6d5a980b35e72b08e4a3330ddc2ecb718493fe87a3f9b9dc879b4bf391b64e53dbebb367ede494b27ede0abe4c5b018f63d4694
+EBUILD importlib_resources-1.0.2-r2.ebuild 1039 BLAKE2B 3419970975065c65ad0f1eeadbdb0eebaf74528391fca9958ed9d4cf7fb3de406b2a74b3a28d8a0e9c4cc4eba7c4d4a59bae2e4ee1ead8b21461f95d1a0bfc0c SHA512 91a66ea5b7046bcf65769e0c4a59ac1895be23d2073a0601c5583e7200c36b1fc0d3493c96e49ee0addd82ec4d24590168cbbd2cbac58924a0a09fd116aa531d
MISC metadata.xml 1121 BLAKE2B 51c2d6c7fbdd7da49d9eb489e8268cb7d5ac85c0ed2505784b377cafed49c29fbc895ae5aa831418175f6f826822a92b6491fc82cbffea428a33b9cba76d0408 SHA512 99fd2fc5abc3deafdfc7eab5e159c80836c3b58ddab63e9bf74f102ca917567be0c5068870206410e82937cdb05d68cb9964402bae9291bc3028417cd316f8cf
diff --git a/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild b/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..d179907d9e97
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-1.0.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is a backport of Python 3.7's importlib.resources
+PYTHON_COMPAT=( pypy3 python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
+ virtual/python-typing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx importlib_resources/docs
+
+# https://gitlab.com/python-devs/importlib_resources/issues/71
+PATCHES=( "${FILESDIR}/${P}-skip-wheel.patch" )
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! python_is_python3; then
+ rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}