summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
commit6d44cd74809cea5f81bf52ff9cd0aa902d6b6866 (patch)
tree4045142b80c7e0479c627a84e3f0de03e574df19 /dev-python/importlib_resources
parent8615c518b1f1d03130f21656a1a026959bb1e9c9 (diff)
gentoo auto-resync : 07:12:2022 - 21:14:14
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest2
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.10.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 310a741e532e..7f9b8df0478e 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,3 +1,5 @@
DIST importlib_resources-5.10.0.gh.tar.gz 34195 BLAKE2B 9b9fc1c33de8a0072edb28a0a67ae73b6830a4d0e16ebfa28bdeaff1409b2f9aeafc84e24f1187cc4ac1b36de78fdecc25acb4a1839ff5fd32f1c38124a98ff2 SHA512 3cf2bdea4fa4572402236ff71678376398d8cae4e87f08487100792275976047a5ee4f024308f1727758ba15ba2f03ed02d8cb95f2d9875c77842a5d24f7f384
+DIST importlib_resources-5.10.1.gh.tar.gz 34781 BLAKE2B 63b516e1bd9cdb141751dc432944b520227a9b5e18b814db8204e1a5820a410d6101a2c902d25855796d3d1fbb790e2bc1f9327a47f828e946419fb8e787fb4e SHA512 1a3a6e36e30d72ceefe014beafc668624975c74e1ac4c2f526c377443e93792e432f4aa22d3c7d08101dabf906f50227f8716a0ee7f60d62ea24ca99641f8c67
EBUILD importlib_resources-5.10.0.ebuild 1293 BLAKE2B 96d73479edc320ca0f2b1689535980d56773491287220d6660255b61688ea5828a4b17e6c381e32942dded7fa732bd13f5823ca01210734e5f1e99f7abc2e67d SHA512 ba3f9d137fb65cc8ac5077fd77fba18c7969de6ddf065294a2bca5c33db1e331523091a3a232512d5bdeacb96405d169ce8136ae44061b3b5633ed8cf420fd0f
+EBUILD importlib_resources-5.10.1.ebuild 1301 BLAKE2B 6b22aff31454e6ddee4bb1ad24f2b09a0a01a3ad7b17e211abe3561ce671a07f900aec8ad8dc8f70cd1fd78926b5fe0c6eba4f33309eb07de95ff25d3306913a SHA512 9121bf2b4412c84a0a87ff116b4313a83a3bbd18932c576deb894cdb1e7c80276daeb6790214d99183e624e77869cd1b94a093725dd44da4a98b3e93a44f0253
MISC metadata.xml 945 BLAKE2B 130dc56a13a8416168baf91e804e1fdef0d65978641c3fca5eb663b8accb5b1adc066bc4033751f03a9c729e27d0448925a7b623431922056fb7d282db052734 SHA512 ccb23df48a89f69133469722fb37acf516127b207b946cdea240cf82e2ba5422ee4e2166d1a9419031408a7624a52256e322fe7e478a9a7b8214ab4bc5c9b92b
diff --git a/dev-python/importlib_resources/importlib_resources-5.10.1.ebuild b/dev-python/importlib_resources/importlib_resources-5.10.1.ebuild
new file mode 100644
index 000000000000..7fbce509df31
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-5.10.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="
+ https://github.com/python/importlib_resources/
+ https://pypi.org/project/importlib-resources/
+"
+SRC_URI="
+ https://github.com/python/importlib_resources/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/zipp-3.7.0-r1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+distutils_enable_tests unittest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "importlib_resources"
+ version = "${PV}"
+ description = "Read resources from Python packages"
+ EOF
+}