summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/importlib_resources/importlib_resources-3.0.0.ebuild')
-rw-r--r--dev-python/importlib_resources/importlib_resources-3.0.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild b/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
deleted file mode 100644
index 39499d3eb2f2..000000000000
--- a/dev-python/importlib_resources/importlib_resources-3.0.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# This is a backport of Python 3.9's importlib.resources
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/pathlib2[${PYTHON_USEDEP}]
- dev-python/singledispatch[${PYTHON_USEDEP}]
- dev-python/typing[${PYTHON_USEDEP}]
- ' -2)
- $(python_gen_cond_dep 'dev-python/zipp[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
-"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
-
-python_compile() {
- distutils-r1_python_compile
- if ! python_is_python3; then
- rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
- fi
-}
-
-python_install() {
- distutils-r1_python_install --skip-build
-}