summaryrefslogtreecommitdiff
path: root/dev-python/immutables/immutables-0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/immutables/immutables-0.16.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/immutables/immutables-0.16.ebuild')
-rw-r--r--dev-python/immutables/immutables-0.16.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/immutables/immutables-0.16.ebuild b/dev-python/immutables/immutables-0.16.ebuild
deleted file mode 100644
index bff5d2a27f79..000000000000
--- a/dev-python/immutables/immutables-0.16.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A high-performance immutable mapping type for Python"
-HOMEPAGE="https://github.com/MagicStack/immutables"
-SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/mypy/d' tests/conftest.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # force running from BUILD_DIR to get the C extension tested
- cp -r tests "${BUILD_DIR}"/lib || die
- cd "${BUILD_DIR}"/lib || die
- epytest tests --ignore tests/test_mypy.py
- rm -r tests || die
-}