summaryrefslogtreecommitdiff
path: root/dev-python/immutables/immutables-0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-python/immutables/immutables-0.16.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-python/immutables/immutables-0.16.ebuild')
-rw-r--r--dev-python/immutables/immutables-0.16.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/immutables/immutables-0.16.ebuild b/dev-python/immutables/immutables-0.16.ebuild
new file mode 100644
index 000000000000..a384f3130478
--- /dev/null
+++ b/dev-python/immutables/immutables-0.16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="https://github.com/MagicStack/immutables"
+SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/mypy/d' tests/conftest.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # force running from BUILD_DIR to get the C extension tested
+ cp -r tests "${BUILD_DIR}"/lib || die
+ cd "${BUILD_DIR}"/lib || die
+ epytest tests --ignore tests/test_mypy.py
+ rm -r tests || die
+}