summaryrefslogtreecommitdiff
path: root/dev-python/immutabledict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
commit20deac35b03e3e15d55e2cfd0236308f20bead59 (patch)
tree025d381424ca1c394c0f8e538633cd942f5ee490 /dev-python/immutabledict
parentfc3556aa4466d278bff2aef2f88113089def0bab (diff)
gentoo auto-resync : 05:07:2023 - 10:11:01
Diffstat (limited to 'dev-python/immutabledict')
-rw-r--r--dev-python/immutabledict/Manifest2
-rw-r--r--dev-python/immutabledict/immutabledict-2.2.5.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/immutabledict/Manifest b/dev-python/immutabledict/Manifest
index f13cf3336ea9..6e68d989501d 100644
--- a/dev-python/immutabledict/Manifest
+++ b/dev-python/immutabledict/Manifest
@@ -1,3 +1,5 @@
DIST immutabledict-2.2.4.tar.gz 4314 BLAKE2B fb971bd1a7f2e577131cd19d97e6eae840ad8ea4a3eda96ff54e20235202b791029e2f76b19980c54ab2679ad7147ef420e3ba237e01f5da303efa8108f218cd SHA512 436e39ac98ea9e8ad262113ef6d8ad629800adf29eda5c064e679167d57515d90165ec4a14e572281711f1a26ae0ea3f2164b6487024b20c31895f966fc0050a
+DIST immutabledict-2.2.5.tar.gz 4316 BLAKE2B 2f251c8409a88cfba741cc9ee2b72d486a7dd8422ca4d841d47246beef506762781106300d9cd4ec8f57115950b09f09bacbb1bc3ceeb0a4b78ef5ba32d3e045 SHA512 3bd94d077f599b6e96a4e17a0d9ecf6365975afe73048f9d9de4df35a8272af1baed264ad84ae6826dd6359ad0d371cd90082b4a064cc6350a0e61bc1cf8c713
EBUILD immutabledict-2.2.4.ebuild 431 BLAKE2B e2544106cf6934ee6009ab2a45cbf6012b66cfda7874c50d7a46b3cf8c97f0141033c53e9fe12365d2eab6352bf922be6f6d53462805a36d74a5d350282b7783 SHA512 9531498803bc784554579112ff6b4c01b2cd2145c89fb3fbb565431492b630b4caabcedc8b81a5fc403354f99460683fc4c259e3590bce265b9d1c0fabeaf972
+EBUILD immutabledict-2.2.5.ebuild 432 BLAKE2B 8d1df8264f81e9f0efd4ce23a15dfc4128aaa9fcbb778b1072a1188998f8ce2f574cf929984628cc56d5fc1d7bb6273a1326036f0084fadeb3924f3fadf9a512 SHA512 b4e030a95dc96967f51f9a3ec8f8ab80cd554dc39ea813394d81e8fc11de1b9017ac5add18f70da57bc972b40d352a79a06278ad66c6aa5e3a089c23aba41391
MISC metadata.xml 554 BLAKE2B 0b375fc6fe772da40d9e33ee6ba495a0c8f514816191621754f836ab45c87dd0430a3139b880e782db1b9ef12919824887ae61858386f438d7421e6e93a418e4 SHA512 064046ff49e9b536aaf0793fdf9c884f745f9c135897d40713961ccb308bbad27c94dad2ddfff42714122656fb398cf3ae849ab3a87f2a71aaf13d900203a55d
diff --git a/dev-python/immutabledict/immutabledict-2.2.5.ebuild b/dev-python/immutabledict/immutabledict-2.2.5.ebuild
new file mode 100644
index 000000000000..2186bb61ba75
--- /dev/null
+++ b/dev-python/immutabledict/immutabledict-2.2.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="An immutable wrapper around dictionaries"
+HOMEPAGE="
+ https://github.com/corenting/immutabledict/
+ https://pypi.org/project/immutabledict/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+distutils_enable_tests pytest