summaryrefslogtreecommitdiff
path: root/dev-python/imexam
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/imexam
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/imexam')
-rw-r--r--dev-python/imexam/Manifest4
-rw-r--r--dev-python/imexam/files/imexam-0.7.1-system-xpa.patch52
-rw-r--r--dev-python/imexam/imexam-0.7.1.ebuild54
-rw-r--r--dev-python/imexam/metadata.xml21
4 files changed, 131 insertions, 0 deletions
diff --git a/dev-python/imexam/Manifest b/dev-python/imexam/Manifest
new file mode 100644
index 000000000000..452fec21ca49
--- /dev/null
+++ b/dev-python/imexam/Manifest
@@ -0,0 +1,4 @@
+AUX imexam-0.7.1-system-xpa.patch 1902 BLAKE2B 92717b9bb17af55b30a936712113ef50fbe079dda5b4a15085f32f65e8a1fc95b936d4a4be316f423b3ac7b9e5cd686a5725b4d75f0062d3e0f34fdc94a8bfeb SHA512 c0f337fcae6db9eaac30e54f57efdc53a162be1500aa67bb7adde152af6a53560cb1449c95e1029c16584acbdbf6e5b7b55e6a720cb9a8e4a8255beee6d6a992
+DIST imexam-0.7.1.tar.gz 20264259 BLAKE2B 0cda1ca386997b0e98d47af47a549993fe4d23b4d5e7a7620b1077adc7d51301009a5c57a7a79776ee15a8efeb572a8b1628d7b21a8b404a94f53ae525ca8a16 SHA512 cb09d1764de19333fa6be1bbb9e6efd3d59943fdef4ccac4e8429e436dd615fa5be3a06c9473cc2c3ff1de1a8987d02ef24765de5b36131c31451b013be8d776
+EBUILD imexam-0.7.1.ebuild 1443 BLAKE2B ffb516c696041816305c22eb73ffb5ae0c5177d84217d29766ea2538433e9bb52fe090d48de50b98cb5dfd9a61bafaf49df38b0ec1ecff05fa90dac47faa3d84 SHA512 149115215293ad5b44ba77a6eb2506e12c36ff5666230457699a8cbd64f06f232451d39bf75ddfec627137f223eada11bba8d8436cd99a1b2ae0be1e4a7b1f93
+MISC metadata.xml 903 BLAKE2B 8e0b16ce360a799e0c96cb6674dad4b05aeb1a30d343c75d084f203ed536137f47d08fcc1e443bfb642f77653271e427029060150ef67f6433b828ee91dda8f4 SHA512 40598f07aa51ad664d0368303e30ccda539db5ad0293e6349fc02b0555a6562c6b58ddda8fea6c31d80c96dffdf7262a68a516fac1b2eee9d0e0d3f4daee7417
diff --git a/dev-python/imexam/files/imexam-0.7.1-system-xpa.patch b/dev-python/imexam/files/imexam-0.7.1-system-xpa.patch
new file mode 100644
index 000000000000..fc90ffef7f34
--- /dev/null
+++ b/dev-python/imexam/files/imexam-0.7.1-system-xpa.patch
@@ -0,0 +1,52 @@
+From: Ole Streicher <ole@aip.de>
+Date: Fri, 21 Apr 2017 13:40:06 +0200
+Subject: Use external xpa
+
+---
+ setup.py | 15 +++------------
+ 1 file changed, 3 insertions(+), 12 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index f0dd5d5..f291201 100644
+--- a/setup.py
++++ b/setup.py
+@@ -121,24 +121,20 @@ if not sys.platform.startswith('win'):
+ xpaio.c
+ """.split()
+
+- XPA_SOURCES = [os.path.join(XPALIB_DIR, c) for c in XPA_FILES]
+- XPALIB_DEFINES = [("HAVE_CONFIG_H", "1")]
++ XPA_SOURCES = []
++ XPALIB_DEFINES = []
+ XPA_SOURCES.append(CYTHON_SOURCE)
+
+ xpa_module = Extension("xpa",
+ sources=XPA_SOURCES,
+- include_dirs=[XPALIB_DIR],
+ define_macros=XPALIB_DEFINES,
+- depends=[CONF_H_NAME],
++ libraries = ['xpa'],
+ )
+ if use_cython:
+ ext = cythonize(xpa_module)
+
+ class my_clean(clean):
+ def run(self):
+- import subprocess
+- subprocess.call(["make", "clean"],
+- cwd=XPALIB_DIR)
+ if os.access(CONF_H_NAME, os.F_OK):
+ os.remove(CONF_H_NAME)
+ os.remove("wrappers/xpa.c")
+@@ -147,11 +143,6 @@ if not sys.platform.startswith('win'):
+
+ class build_ext_with_configure(build_ext):
+ def build_extensions(self):
+- import subprocess
+- subprocess.call(["make", "-f", "Makefile", "clean"],
+- cwd=XPALIB_DIR)
+- subprocess.call(["sh", "./configure"], cwd=XPALIB_DIR)
+- subprocess.call(["make", "-f", "Makefile"], cwd=XPALIB_DIR)
+ build_ext.build_extensions(self)
+
+ cmdclass.update({'build_ext': build_ext_with_configure,
diff --git a/dev-python/imexam/imexam-0.7.1.ebuild b/dev-python/imexam/imexam-0.7.1.ebuild
new file mode 100644
index 000000000000..65296b55c7c1
--- /dev/null
+++ b/dev-python/imexam/imexam-0.7.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Simple interactive astronomical image examination and plotting"
+HOMEPAGE="https://imexam.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/ginga[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${P}-system-xpa.patch )
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ echo "backend: Agg" > "${T}"/matplotlibrc || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${T}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_docs --no-intersphinx
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test -v
+}
diff --git a/dev-python/imexam/metadata.xml b/dev-python/imexam/metadata.xml
new file mode 100644
index 000000000000..6a478af7b2bf
--- /dev/null
+++ b/dev-python/imexam/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Imexam is an affiliated package of AstroPy. It was designed to be a
+ lightweight library which enables users to explore data using common
+ methods which are consistent across viewers. It can be used from a
+ command line interface, through a Jupyter notebook or through a
+ Jupyter console. It can be used with multiple viewers, such as DS9 or
+ Ginga, or without a viewer as a simple library to make plots and grab
+ quick photometry information.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">imexam</remote-id>
+ <remote-id type="github">spacetelescope/imexam</remote-id>
+ </upstream>
+</pkgmetadata>