summaryrefslogtreecommitdiff
path: root/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-02 00:07:23 +0100
commit6657c680376cedf378fcf328e5fa03ed3b41d580 (patch)
tree44ea8d174f647daca562b9bdcbcb527a85a77d0a /dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.0.ebuild
parent1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (diff)
gentoo auto-resync : 02:06:2024 - 00:07:23
Diffstat (limited to 'dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.0.ebuild')
-rw-r--r--dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.0.ebuild b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.0.ebuild
new file mode 100644
index 000000000000..ccbb512610be
--- /dev/null
+++ b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="FFMPEG wrapper for Python"
+HOMEPAGE="
+ https://github.com/imageio/imageio-ffmpeg/
+ https://pypi.org/project/imageio-ffmpeg/
+"
+SRC_URI="
+ https://github.com/imageio/imageio-ffmpeg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+# ffmpeg is used as an executable during runtime
+RDEPEND="
+ media-video/ffmpeg:*
+"
+
+distutils_enable_tests pytest