summaryrefslogtreecommitdiff
path: root/dev-python/ijson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-python/ijson
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest4
-rw-r--r--dev-python/ijson/ijson-2.5.1.ebuild23
-rw-r--r--dev-python/ijson/metadata.xml2
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index 838818ebf34a..e10530698935 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1,5 +1,7 @@
DIST ijson-2.3.tar.gz 11800 BLAKE2B 0cdd2a40c483341dd9dcd4e7cb52c38752886d02e5b0c5982bad975487391cac31e2b5993118fbb526f91866dc8441a711ec16e0e8f1d320d32eb026bb4c8b0d SHA512 4d6647cb72661b26a3b36addeabec79fbc047a6c3b86aa419c178dfb8ef09bcdefdf37ed729f26b4b6b176cec06230ef3dab53bdff4c4b401bbc835eb486d038
DIST ijson-2.4.tar.gz 17570 BLAKE2B 98301c5572597ab9a52c33dd92e1a2bf1fa9956415f21a49b13de438a6f295221da43c110f94aa280834b85993f4c8a3cfdaa060f28598e5af50510e7657561f SHA512 c93548a0719a9de30d504dd6179dbffedfd91228ef57fe6600af30eaa2338a2b720e6c9c5b386868198945714a725d46dd2dee6a1ae6d6a0d61eb0230eb35608
+DIST ijson-2.5.1.tar.gz 23258 BLAKE2B e41cb4d903399384a1a1d18941a2ecf36e80c762e5d4e3e854e9337f3a72cab3a61576d9d5170b11e1513bd82ca0e2158b8a88d4c30855674366fbc9172c5042 SHA512 f8d2cf0496357d3385e2744a4604cef1fd6fcd92cbd52c8803d7e831c091c18b718ad0c1dc8735c3f10df04e25fe69ef73d6935b2df6f67845493935e2ca529e
EBUILD ijson-2.3.ebuild 572 BLAKE2B 83129c0128d58ad72e59247802719fb411d87df199049b8da127fdce10420d44a64166a612ba57482608457fbd7bb9295353c7aeb2ba90bbacb136e927926968 SHA512 34ab27be8015a47e18d149cc874812b45b67721c1a70a62264836360516fb12aabf336cd70d79f6dce3ab2f2676a60012ad12dab8f35532ce1fe5cf8285df77b
EBUILD ijson-2.4.ebuild 617 BLAKE2B 58c80d28c3a87add553363b1046ad4b32f7cbec378fa45beabe53c0a8ac13421db9dbec1ec04e43858bb49636051caa26034c7b64226a53154b4069f48d38bbc SHA512 183fd41f6d35bac0111ed3c14cf1e2d6c13f6f30f859840c7ddd933ea18c10bc4f5a6b1ffde094994ec9b5016b31ea7fac22f1c802f35a313e0140f4ad450665
-MISC metadata.xml 375 BLAKE2B b0b47eb0f90d6dcf828b9c06d77d6292119cfdf53c6c7c694a478c20e16c677fdaaa9a6e443fa985af91658d1e258eb09642fd259d58793e6ab7d20ed979ade2 SHA512 99d84d8cbffb0864a3473385642d96238a3ec4679b13d60361ce147536e58780978ac5ca947533fd25d97f05ec9b011ce3a831c05b90a24281b828b03fb80919
+EBUILD ijson-2.5.1.ebuild 587 BLAKE2B 2fba7d9448ce618819e438eb1bbc14f8cb710c96ac5f93cdba71d22f630934cdf3696fe5a501464053c2e7b282199d8c671544e5149b5a82f3a6586da31d64e4 SHA512 64fe70951eba5ff1a14612420f39c4ea1902a7599290815588fbe27ab590783539ce70874a6a3876e4d31132a0c3f4c9d6730cf70e1438da45aa2dc4cf3c552f
+MISC metadata.xml 371 BLAKE2B b69568a1fd9e7578de49b729826c1bae5b6aef3c6e34d3c32adb9745e4bbb0541fe1e43730fff84aa0dc85b3b116c1e4fb9d9301b3c0f1f8c615c24141b1657b SHA512 874354dc3c06b919b563b13b0b0dd64b9e5af1fd759d199691d2e45a3ddf3fac61412452a0c746c22cb43c3eef379f3c391c2cb04d109ad6859ca279566e1108
diff --git a/dev-python/ijson/ijson-2.5.1.ebuild b/dev-python/ijson/ijson-2.5.1.ebuild
new file mode 100644
index 000000000000..91941962119c
--- /dev/null
+++ b/dev-python/ijson/ijson-2.5.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="https://github.com/ICRAR/ijson https://pypi.org/project/ijson/"
+SRC_URI="https://github.com/ICRAR/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}
diff --git a/dev-python/ijson/metadata.xml b/dev-python/ijson/metadata.xml
index dfdc2dc6c0eb..72fd239d1c33 100644
--- a/dev-python/ijson/metadata.xml
+++ b/dev-python/ijson/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">ijson</remote-id>
- <remote-id type="github">isagalaev/ijson</remote-id>
+ <remote-id type="github">ICRAR/ijson</remote-id>
</upstream>
</pkgmetadata>