summaryrefslogtreecommitdiff
path: root/dev-python/identify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/identify
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest2
-rw-r--r--dev-python/identify/identify-2.4.1.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index a9bcd118ea28..b8ff3d1e1cc2 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,3 +1,5 @@
DIST identify-2.4.0.tar.gz 101312 BLAKE2B 1ba4fcf235518427fba8a59eb30ceb0c20ed23f5a3c4f56d6039ab530aaaba6b83ee395626a7d086f193f57f00a8d34a659883d897a21dc0fae5018cb0a4e87a SHA512 f0806d3785ef5db9cb1b5354c146fc0d33b4a4f04b3ff899945e9e93273a0bf8e4c8ff07ace22b5d71721c953148c007630dc400b82849321e8399ecdfffbc85
+DIST identify-2.4.1.tar.gz 101282 BLAKE2B e7c04480159062ec25063d956dda6d904031bbcc30fdab6011ad24a8c3816490d0dfe08cec19fdfe660509a246da820ccfe41d4dcd909daa9c59b622bf506148 SHA512 69253bd364ed96ae64d83ee25da0d9aae97731e602f193008471dd99f47db2b87aa33dda1f87fb9edf939992e0452ca45f07f1d7d5e628352b50d4c2e68b7d0e
EBUILD identify-2.4.0.ebuild 516 BLAKE2B 9e67c4cbb998fad7f8fee2583b0553822dc9dc7d589a092b1127938f48999afc05e1aaef3ba5d3eb1f85d9ae399268c82869eb4bf3ae4274bdbd65b41f14ede8 SHA512 47c7d88fda8e395b105ea8ecbcff161729a21d89717292d393b31e538bcd8c5cf6fe46b0f7249ce20ebe9b10eb7105bbb99a383358bb8843b0754d95d2fc2e3e
+EBUILD identify-2.4.1.ebuild 518 BLAKE2B 4327428e4d169fceba95c9d444157fd626ec810e3e1036514f1e241497cbd1f72c7fa014f7011d8b65e94b0fb750ff442ced7d5047ef9c04ce79a7e26f947148 SHA512 9d8f344351ebbf673680e90335a49802ad3534da08ec2d1fe81df6fd5e8f5489974f17c264a6d34ebe26e99fe27331fbae9f808f498b554e8d3aed0e163f31f0
MISC metadata.xml 477 BLAKE2B 068a0df0204ecc3f2ad9729c0a6b66b0895f94a08852453c4dcafeb784068857a4baaef55eaf0d9b742d4bfad98a2734b11f8647b52182b7ffaaa04656d8e457 SHA512 79798b3778c546a0105fa02b2cb0b682577ed630bfa7a5ff70a188441f6f847a59cf9179eb6284e7159127b180c990ed6265fdd88e78cecd00fff9a8a7461518
diff --git a/dev-python/identify/identify-2.4.1.ebuild b/dev-python/identify/identify-2.4.1.ebuild
new file mode 100644
index 000000000000..9ed5ce5e19fe
--- /dev/null
+++ b/dev-python/identify/identify-2.4.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest