summaryrefslogtreecommitdiff
path: root/dev-python/icalendar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
commite937ca8df21d3186f65edc11c872706c80eb8a61 (patch)
tree6758813cd0a8bd1da09045a9171ff389b1b39718 /dev-python/icalendar
parent1b5d79237a144dcb8753c783941843d879a906e2 (diff)
gentoo auto-resync : 20:03:2024 - 13:00:14
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest2
-rw-r--r--dev-python/icalendar/icalendar-5.0.12.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 9a4eea1132bf..0e6e7a88289e 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,3 +1,5 @@
DIST icalendar-5.0.11.tar.gz 112178 BLAKE2B 6b71d0a391643435729ed39caadffb0aff6893be26d1e3bd887a69d9156df30d0b798fb3c5d2f268f602a9953400a30c3aae49698008108f2ba810d2bba1eb5e SHA512 ac567ac761fde076d5895a3353fff4de9244847689d4f5366d918223a49f1ffa87063f8bb55b7458092369482868e40d2c9925ea7d95e77feeaf3d9711a5b7d9
+DIST icalendar-5.0.12.tar.gz 115981 BLAKE2B b6a778f78977b2e967f639ca1a6209002c003c0729a993217da2fa7d3e407d5fa696740daae7b3c1084588140675a2fb1346b39042fe869195d917b3a2436f49 SHA512 0b608054b955223c1b876c8395b94a501f6b5afb92285561750749882cde2d55cbb48487f7fcd64188d2d6cd193f3bdb5634871352eb5b7a445c483075a62453
EBUILD icalendar-5.0.11.ebuild 887 BLAKE2B d27de6e8192bfd75a7ac0e19fd13ce17bfe25bd0bddc9d1cc33ddde3e26a061871f36ad28b05d58e3739170e59b06e5ba047328843d0b8a8da0d2baa0a5a98df SHA512 e61d7d588541ae034aa3844aa14b6cb8a3b3d90396b4cc358b9ba1796d845a71b64e56a45d874dea7fd3738470263e76fe8f37f1342cb3afbcb212ce70975924
+EBUILD icalendar-5.0.12.ebuild 892 BLAKE2B 7836dd8dc4a688c093ca24d662dadf9a58783d2f1e698a65cc7f2156106a4c6b6a418f7b219c553dcadd5b65d57a180e669eddee6c7e6fbbcb7badd0b8b8f937 SHA512 e6c1dfd7a1bf2d6273f868e141c3664eac5657c583f176a67000b4363b7a408c5fe301dd4a505ea19fe85ce9d1d55e9989000e39a1f1d7b26de8af63f0637d7a
MISC metadata.xml 503 BLAKE2B 284f63e95eb2d3015979a14774f8ff9df0df701b81f8aa2c7583f52d05973cfede1db8eb7904203b854165e10640cc50a0e3cf14d9aff090d9ff657c53098cee SHA512 d206db3c1255c8e475c4289c548f0224c7fc507aae513d3c15706998892ef8450400a97bd07dc7d52142a03cad4abae3595d5315d8912586440df74096edea67
diff --git a/dev-python/icalendar/icalendar-5.0.12.ebuild b/dev-python/icalendar/icalendar-5.0.12.ebuild
new file mode 100644
index 000000000000..8e6ce208d2d6
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}