summaryrefslogtreecommitdiff
path: root/dev-python/icalendar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-30 08:16:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-30 08:16:57 +0000
commita21eae5570ee23ff259ccee6adc402fa27578a83 (patch)
tree0507ed3791ad67e98a33cc87b0a485409d6b3e77 /dev-python/icalendar
parentb7cf34e541f10778605d8740e2690d8459908ac5 (diff)
gentoo auto-resync : 30:12:2022 - 08:16:57
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest2
-rw-r--r--dev-python/icalendar/icalendar-5.0.4.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 28b4c21d414d..4d37f2db2025 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,3 +1,5 @@
DIST icalendar-5.0.3.tar.gz 101431 BLAKE2B 4c98880f661c5cd8025e7e281dbd392ff9333c3a4c3850d7826cbbb15401d0916e24c1478ac3098c58709a065f3de21b7d8fea56ad7df40aec06b989a77deac5 SHA512 ee278a4776cbac3dfa99e8931fc48be49b06e3354689c8d5132ff53092edb913c24a61a69dac7f5de3defdb929a6b53374209d3f7a8dd5af53f414e5aadfa44f
+DIST icalendar-5.0.4.tar.gz 102093 BLAKE2B 5bb618f8abfa8c96cdf45b0fd85f97ecfbe99361fb2eda08fe6ba43da1d01642e116218bc01353a745f6dc401278887d5ffc616fcf666691360174459c896362 SHA512 5b9b1b770c903bec4d8e5a4dc20b82d8e35eb86e6421d62abad640e65db20ccc71757a939e9ccb051653962ab5725e80dbc024703de158fee2cb0d608b8b5732
EBUILD icalendar-5.0.3.ebuild 1015 BLAKE2B 215e568a91ba34b61a865fba669f4a6dbe1ef15bbd972d05f4e4eae20502a7363708a36ef279dee651841fcd80007d223dee84d86035e705e8de0f3eb4ee2928 SHA512 2c954a2f3b4d5053cf284e1692753dfe305a496100ea5630f6ab1bce2e8d4ec23db22c57ebf8a5e14c2611f7c4aec284790cb6b7bd7455b4f0b69a55065082f9
+EBUILD icalendar-5.0.4.ebuild 1017 BLAKE2B b67fda0e16185d243a0989256bdd1342469293c0f127692e354bc2b3dfb8e0e797d87d2d4b02a597179b6c92ee50820eaaa15d98ecb3847b2cbb4ee8d31d94dd SHA512 da2af57bca5c43ba592151bd627afd8bc021f0d7649d2eee88af88c551cfd86d43439fd32f8c2d63f999793af9bb153d6985350e4d5be38ca5b8049bf5ee34a8
MISC metadata.xml 503 BLAKE2B 284f63e95eb2d3015979a14774f8ff9df0df701b81f8aa2c7583f52d05973cfede1db8eb7904203b854165e10640cc50a0e3cf14d9aff090d9ff657c53098cee SHA512 d206db3c1255c8e475c4289c548f0224c7fc507aae513d3c15706998892ef8450400a97bd07dc7d52142a03cad4abae3595d5315d8912586440df74096edea67
diff --git a/dev-python/icalendar/icalendar-5.0.4.ebuild b/dev-python/icalendar/icalendar-5.0.4.ebuild
new file mode 100644
index 000000000000..c68083d1dacb
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}