summaryrefslogtreecommitdiff
path: root/dev-python/icalendar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
commit1d18b53ed419c49eb3f71637ccd58a431c1368d4 (patch)
treeeb3671b1209855aa64534ee96262d06bcda99d74 /dev-python/icalendar
parentfdca6388cf31827202fae75cae067c695bd09339 (diff)
gentoo auto-resync : 14:04:2023 - 05:44:49
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest2
-rw-r--r--dev-python/icalendar/icalendar-5.0.5.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 1030bed9b5a9..44a11e617115 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,3 +1,5 @@
DIST icalendar-5.0.4.tar.gz 102093 BLAKE2B 5bb618f8abfa8c96cdf45b0fd85f97ecfbe99361fb2eda08fe6ba43da1d01642e116218bc01353a745f6dc401278887d5ffc616fcf666691360174459c896362 SHA512 5b9b1b770c903bec4d8e5a4dc20b82d8e35eb86e6421d62abad640e65db20ccc71757a939e9ccb051653962ab5725e80dbc024703de158fee2cb0d608b8b5732
+DIST icalendar-5.0.5.tar.gz 103204 BLAKE2B 20887b535f595ab222f3aca8ac396a71b53975816663693f89277a03be41885780d0b15269cd5955e00eeda0867db46781ea2300f542bca1a18687d50e025989 SHA512 1c1e6c94e2caa07686bc12389c3a5b823478f1652695bc167af95c26f92bbd3d60fb4e540d74eb90db289c647bfd6e1c82e83ee8f89bc87b80100d8b6fe5dd90
EBUILD icalendar-5.0.4.ebuild 970 BLAKE2B 2e9b781f2c304954051b413dd5a0452d79b93359d65780b03e6fb989ea717b41aa7739ccc5f02f3ac0eb3714f65266edbf88a19a4625d48bd3bc7b4bea69c3e3 SHA512 3bd0182cff301cd0e743ff1e20a7042b4ca6afb1a932d3f3ad07a6a6942835235759c8fabf0ed459976c0bf8271a990bda4743806d6f671bd3ba2b5ecc5edd8e
+EBUILD icalendar-5.0.5.ebuild 972 BLAKE2B bf8787872482da11a85ebcb2bbf83aec3d8a3a494b32ffb744b924dce695fb94043f4728fd33b04d41a0aa1d44c7e1d97491451d39fdd5d1bd16acbcc5ba0c34 SHA512 a804835da86bc95817222403f83a287d0ee451c2896a751769be80502072d9f03d9eb600a270c9eb115c1e95bcb7023a4ade661af1aee555cd126e6a18853d59
MISC metadata.xml 503 BLAKE2B 284f63e95eb2d3015979a14774f8ff9df0df701b81f8aa2c7583f52d05973cfede1db8eb7904203b854165e10640cc50a0e3cf14d9aff090d9ff657c53098cee SHA512 d206db3c1255c8e475c4289c548f0224c7fc507aae513d3c15706998892ef8450400a97bd07dc7d52142a03cad4abae3595d5315d8912586440df74096edea67
diff --git a/dev-python/icalendar/icalendar-5.0.5.ebuild b/dev-python/icalendar/icalendar-5.0.5.ebuild
new file mode 100644
index 000000000000..163646f7a292
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}