summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/hypothesis
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest5
-rw-r--r--dev-python/hypothesis/hypothesis-3.59.1.ebuild37
-rw-r--r--dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild29
-rw-r--r--dev-python/hypothesis/metadata.xml12
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
new file mode 100644
index 000000000000..442cf33a6150
--- /dev/null
+++ b/dev-python/hypothesis/Manifest
@@ -0,0 +1,5 @@
+DIST hypothesis-3.6.0.tar.gz 73586 BLAKE2B b0ec133e8c71f752114211061155c15a7d536e771ba85eab6489440b2063d3083018bf8502d9e9dbc73105ee5f03060e3189e64574a3dfa052b091040e7e7915 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389
+DIST hypothesis-python-3.59.1.tar.gz 500529 BLAKE2B 5c171045e363f2337d7ca30797b9fc7f96430c805dd4b3ec78fe927247d2c2ba4a216789a82f1e956b89d66c5ecdb2050a5f93467f2d557a05d1d48507fc06db SHA512 c3aad4cc54152963806e09af5f351e60e30cd64ad48ba3d922451b10dbb1747ea3e5d432ebc611dcb0646687d7e8755051b967304e74798d091be0b2901c832f
+EBUILD hypothesis-3.59.1.ebuild 1170 BLAKE2B c6326b9bb3bce4df347f2d7c789788eaf267fc6559d4c45384dd452a3eec796656fcaf31a5c31f5fca9ac07d5654bce887a4ffb291327456e6b33d6ab04c7478 SHA512 ef94db0bf5cb06cb388f666322a4f46185ba0a300b163341977919ace3cd4feaa2092d511180cd046e39aab6090d3f5d38f9791aab9d9414d825ec3bc94d1b21
+EBUILD hypothesis-3.6.0-r1.ebuild 911 BLAKE2B 4107db5cf3dee7f521f54dbfe0488742ddf21876b88b5b637c361d8808fa09686252e5d464391adb3e2e45737c2e347eb963fc0e49c41a04c0ff84536a131885 SHA512 315866abf6fa890934c3125d86beba7c3bd799f1472c5661725418806f68f20c850b3204b687a03c1887ecdf6a535117446a049509050da5f9d6d93cb0f6cd0b
+MISC metadata.xml 379 BLAKE2B 3623a13a813bf71f9474fa018b2f83392ec168193b9853cabcf112267d38e7278e97a415bb8b7e52f9ebb28864b8709a64996dcb0d97e1f03b3ecb31a944d74d SHA512 40bb5c1916d9027ff81cd32073de34753a30d8430f36d0fd16667a111af8fd222379dcd817edd723d362f5ff5578ad7b212f98388c00de6dff1a64bd2c3978b0
diff --git a/dev-python/hypothesis/hypothesis-3.59.1.ebuild b/dev-python/hypothesis/hypothesis-3.59.1.ebuild
new file mode 100644
index 000000000000..fac7d09e539c
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.59.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild b/dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..c5be695385e7
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*')"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/hypothesis/metadata.xml b/dev-python/hypothesis/metadata.xml
new file mode 100644
index 000000000000..3b9d8f1161a1
--- /dev/null
+++ b/dev-python/hypothesis/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">hypothesis</remote-id>
+ <remote-id type="github">HypothesisWorks/hypothesis</remote-id>
+ </upstream>
+</pkgmetadata>