summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-13 22:25:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-13 22:25:40 +0000
commit48b1a38e1711d2eec2733c3cd4b1b8ae49fbc47a (patch)
treeed7b58155a74c0f8e0e14abd2039331b5303b34e /dev-python/hypothesis
parent554b3dc27cef6db59f8a612c1e2e3c653f70e392 (diff)
gentoo auto-resync : 13:11:2023 - 22:25:40
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.88.4.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index f4b5992c20b7..d61adb6fa064 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,5 +1,7 @@
DIST hypothesis-6.88.1.gh.tar.gz 9391389 BLAKE2B 0d258ff3e662bdef1c8321119c49ae4a8f1191edb316ab6262023c7da667f553b94386c28fcc40bfe06d545ae33a28b907750d4caaee8be7614a1ad578370f25 SHA512 e9376aaacd5cf405f0a28b9a9e63fc1d83506ad286579e1ae2165006cd87af1aefac68e34dd5164159f86bffa3f1da29ce86fc3254dcb11183d653b71377c41d
DIST hypothesis-6.88.3.gh.tar.gz 9391730 BLAKE2B 439b5d4aca9f8163bebb7b0ba632fc1d7eb49a61e656c3849287b700bb92c5aea02a30d816029152243c03050e67351a8a6c4dd87ed6eaadd5a81f5a72c8c139 SHA512 780a83928ffdc976c581df43874a1d1e4ec82d9c27f6bc151e5a4103dd9e4d18de0609af8964136cc041ebec258b1fd2c6438b66636e9cd8e7f81a88381bf5ce
+DIST hypothesis-6.88.4.gh.tar.gz 9392092 BLAKE2B d33e764fc02111f37efa678927d48f1de7097156c401ab85c7a3fc16f22ff3582bfaec8fef60e010d9a9953bcdbbd8f212b5a7765a7967b93d6dd4bb1d6e5915 SHA512 420dd525abb56dad8983b16767cb4d7f4b411ee68439e2317d7be5582fcf9a8735929b4746bbfc37b286d389dcd36c38da797466bd6c4c555d108a56b30511ad
EBUILD hypothesis-6.88.1.ebuild 2475 BLAKE2B 9497be26b5a9c37d122cf9f1f9d6b87a1a24beabb228bb13d8c8e10427ffb1562d8603f36368d0cb0c43ad733b532bd68a9821973e05f89e9e5097fd33cdfaef SHA512 83c2c393c14eb01aff47d47892cb64c16fdb5973ef6e825dd12f4bc5c0962b723ad2ce2ee1f4c4593b261355e41beb261abaf21c3d2f845d65c860fbc6b75e1b
EBUILD hypothesis-6.88.3.ebuild 2483 BLAKE2B bae85fbb1a28d39220bfe9b5f4f0dca5c720b7e6faaf78f38b39dbead435df0048f90b6bd167536ea83c72cd6a058f4c9a23208fabb38d99e1d73e0f180125e7 SHA512 1ea3f5e15d332d9cbff80a71e260f17c7123cc927a284024a2cd53bea51892edba5f0d9e18c5b148e5513383fe73985a10f52262ba49951b5b4e7a7c349d4171
+EBUILD hypothesis-6.88.4.ebuild 2483 BLAKE2B bae85fbb1a28d39220bfe9b5f4f0dca5c720b7e6faaf78f38b39dbead435df0048f90b6bd167536ea83c72cd6a058f4c9a23208fabb38d99e1d73e0f180125e7 SHA512 1ea3f5e15d332d9cbff80a71e260f17c7123cc927a284024a2cd53bea51892edba5f0d9e18c5b148e5513383fe73985a10f52262ba49951b5b4e7a7c349d4171
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.88.4.ebuild b/dev-python/hypothesis/hypothesis-6.88.4.ebuild
new file mode 100644
index 000000000000..5d255dfeb3df
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.88.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}