summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 00:11:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 00:11:33 +0100
commit1013bb04a30c552ec7ff5e3fe97074b0531a024d (patch)
treea94f2330bae429402db01020da9c60782e27af89 /dev-python/hypothesis
parent40c113c340752d507394d37cd6b60abb741daed0 (diff)
gentoo auto-resync : 14:08:2023 - 00:11:33
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.82.4.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index b22750442732..9ad0cfaad9d2 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,5 +1,7 @@
DIST hypothesis-6.81.2.gh.tar.gz 9378154 BLAKE2B d4654e8de621af93fa6ab013bf45ea1c2e8b273f38cf0dddbe00853d197487acf2a9457a33e59fd59b9c5c7dca08a84867a835cdfa8e4a63181df5105889c360 SHA512 41f5e6b8382c08dd0e4285836a3f1308f6666d86387e10899c5ef8839598e097d31a5360cf7d47f2d30c287ad575787ecb44c236ad83c52202cf8895046c56a0
DIST hypothesis-6.82.3.gh.tar.gz 9378981 BLAKE2B bb73131f9982e8df71e24a5f329a2f34b7e895ffa231d55724f84a3d692608e59a4494a820ea5ee449db4c40f2521548b2dece2f1bcfa9fbd4f0ddbc4dbb9756 SHA512 02b649116630dc6be3cbd659a00c9c55d68c85a9cbf029558fc1c065909a1cadd2fb120615fa3bf7fe4a11f51d26d264cf6730ac4d3165798668d38e62c5d955
+DIST hypothesis-6.82.4.gh.tar.gz 9379010 BLAKE2B 0da8b3ff53f6f2019019ade9a8b42ef62eb90993ca1835b89938d0a36387958e4b32bc6c7ac6345f465682c5fd4d549befa30d083d81fa4af611d16c3df07007 SHA512 22d186203b23409e315bf7341bd51e084785c833318cb32a88c81123cdefb1ae757c89bb025209d36adf720e2a407fe28fabf1d3fb2ae0d2e4363cf69adfe72e
EBUILD hypothesis-6.81.2.ebuild 2505 BLAKE2B 3300ad59224b47e57e712fe267ffb203a8133ea8a4034475ca10ba245d7601d4eff5f04ed65033fb71277e5a068ceb1a0eaf9f51d8ca7133967d0eb3b2b677ad SHA512 c8b4e2846301c52b8b8f1a7a610051b9ed1b268b806ec6442a0bed45382203e98796a02992f3edcecd1db6dcdc0799a9d6af70c9f58df119388a0898c45bc611
EBUILD hypothesis-6.82.3.ebuild 2502 BLAKE2B b16e9f92ad6000402fa02a5eb4d1e1367c5359c0b92a213508ced51afc1c93efc34a3eaffe9843eddb66b871ec2cdc009ce6a5990da2ab391b4026386f31387f SHA512 ae1722ba72d73ec70bae25ba9fa00a489ff029b8030e26e6b6d4168043ac7c7ac005db91488b9ea68f015dae929ea0ffd1e18739f7204d36fd3d97bd81b02781
+EBUILD hypothesis-6.82.4.ebuild 2502 BLAKE2B b16e9f92ad6000402fa02a5eb4d1e1367c5359c0b92a213508ced51afc1c93efc34a3eaffe9843eddb66b871ec2cdc009ce6a5990da2ab391b4026386f31387f SHA512 ae1722ba72d73ec70bae25ba9fa00a489ff029b8030e26e6b6d4168043ac7c7ac005db91488b9ea68f015dae929ea0ffd1e18739f7204d36fd3d97bd81b02781
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.82.4.ebuild b/dev-python/hypothesis/hypothesis-6.82.4.ebuild
new file mode 100644
index 000000000000..ed1f0cbc8e14
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.82.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}