summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /dev-python/hypothesis
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.32.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 7eec92bd759f..c108eb70b523 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,5 +1,7 @@
DIST hypothesis-python-6.30.1.tar.gz 9180975 BLAKE2B 3b0e8e29d74f579a9ace6fc341451992386de3358defcf42936d2d535c31bae07d7ab49fa6d4a8d1a2bd0e8231086dd9795d78125555e668425fba2bc539b224 SHA512 8abf31debf94124744d17d5ddac6698a21981feca7b776e97d92d5f6d1404ec17794bdf11b256dc7b0a335a041af6d3f1f20ae6fd6a62abc1ad78c2b39354fa9
DIST hypothesis-python-6.31.4.tar.gz 9183157 BLAKE2B a8c82cd2e798b7dc0b149a09d52cdde77677473d91f3192783a8903fa7513ce410a89e67df32a812a12b59ca113b065c52e84fae0632f8a2dd852f4a39e90cbd SHA512 b1783d7463b575afa40418e4d67aff04c025bd9d733b1c6b2ac671d8d1c9a5d58ee7d10ce5e27aaa14156285abb6b182f7ee5f3ebe8eb335421680d20dbb4405
+DIST hypothesis-python-6.32.1.tar.gz 9176925 BLAKE2B 0b57c8b46b766055a19c8831620b6ad780bd1a3b3e4835496cbd01f4fb861c64679171c685797458ec56ff07fe9524840cffce1e1930390de71225b707163880 SHA512 f64b0ca16a47d9f4dbce4986aa2c4414e86e596b6e167bd8be373fda05f8bbb626de7a615861a71313faebde50b1fe55e54c8b20247c71fa4ecb2223de171502
EBUILD hypothesis-6.30.1.ebuild 1754 BLAKE2B afe7c86d0907a4c0500ff94249349431c435567753fba197261ce9bceedb03da6ecab286780b66ac4c83361528fe93ff4422c8615bbc6ef20faf289efaa3dcf6 SHA512 b3199308c4981d523366fb48c5d6bee4e1d0eeaa3e9854627cdd23b5d81d22ba4bde02b2669368a5d8bbcccdfb3941aa692c78b18524e907d70c24470e284385
EBUILD hypothesis-6.31.4.ebuild 1762 BLAKE2B 160ab670a5db81e8ff41937a560cbb11efc1e9ae4bf41fc85176e9ab7c640e81da405ba4d477261def8f04c3a6b479ced41b7bb1c9b109e82a024bfaae62819f SHA512 2158da223e25cd54f10fd64167d3d25032e1d3647b5dca501f6c2ca8f977ee829550f7526d538b31dc192a9fdacdd9b4fea2f61204db4d0dc94571358af2b2dc
+EBUILD hypothesis-6.32.1.ebuild 1762 BLAKE2B 160ab670a5db81e8ff41937a560cbb11efc1e9ae4bf41fc85176e9ab7c640e81da405ba4d477261def8f04c3a6b479ced41b7bb1c9b109e82a024bfaae62819f SHA512 2158da223e25cd54f10fd64167d3d25032e1d3647b5dca501f6c2ca8f977ee829550f7526d538b31dc192a9fdacdd9b4fea2f61204db4d0dc94571358af2b2dc
MISC metadata.xml 756 BLAKE2B 26e40ab96ddcbd5751023e3c0cc9aa86e96d73ba02bca750ad15eb4301beb0318d3d694c54c2c2a2cb50937731af727411e8afb67e1a21e58e0ff611eeea9149 SHA512 cd48d35c5fe41aa9efcfea9eb7b2d78a4646658b5aab7533ca6492d4700032099fd34ca2dc45a6198c27351650c9e901c8b7c4d53ade2b56695d5e26ca371238
diff --git a/dev-python/hypothesis/hypothesis-6.32.1.ebuild b/dev-python/hypothesis/hypothesis-6.32.1.ebuild
new file mode 100644
index 000000000000..ea716a889cd2
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.32.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{8..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}