summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
commit0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (patch)
treed48a200142b883af377722ab54ec0c1d8c19912f /dev-python/hypothesis
parent6a7029e0f7370d4d5dfe9e31cc2719a870482392 (diff)
gentoo auto-resync : 16:06:2024 - 00:09:44
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.103.2.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 8086760600a6..bac4d62bd750 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,5 +1,7 @@
DIST hypothesis-6.102.6.gh.tar.gz 9462342 BLAKE2B 7daf1cfedd3e8aec72ca2a16a320ccac8c03d62dd02c7b6e20a8c0e8e9510996fc36b5f1050c111ef2eb389b77a9f468b23ef7627867b8d50559c59df003f635 SHA512 aa458c9db8ca0f5661ffc64ae61b08ffe2e93cd1fe5431752aa92339af22cf90b79763d08c6e381dd0875b26b2cfbdad92e95cc581ba325072ec5330223d3b7e
DIST hypothesis-6.103.1.gh.tar.gz 9463631 BLAKE2B 7c7df97ff5702103c3e02d664732cdb2beb32acc51a385b086cd64763822ef8938a75feb522d62335b3392517f8756f60c73d5c681d3cbdf814659a27c94746c SHA512 19e3bd48380ab8a4ce931437e68b224f77441b8c7da99832a18ec1cdeca9609675b8ba19110df33db45ff5c06a1065d21807436e86afe89366510ea36e7f548d
+DIST hypothesis-6.103.2.gh.tar.gz 9463865 BLAKE2B d14882642edf53354a6cc8bdf4fb8ac3a5e93a6d5387186e2bd442447710a3e0e84dc61dee6febb690e85552ec3642df58fb731287a6ffd4fc59bd0c69f4f6a9 SHA512 e18ed2ee70541bf992aae784bed59e4e9b1cd784f2bc35573d3a375fcc749bd0a756b7a2a494a16a04ffca386034bab6f99ae0e25ddb18542af0754df081a359
EBUILD hypothesis-6.102.6.ebuild 2514 BLAKE2B 1ad3d2518c490ef10d8e2fba0719e5ae4d11c1f44a82e1ebb6fc679aec161ed981b386225070090ea825fa154ee1896062db01e9d8d8c0daab1128cbdec7aa03 SHA512 b6116a2392ca288b55936a9e1d57231f64d08eada7a18d65d8f764b01a71afad967ff35102aaf528ac96cebebf344442d0334c4a499c02b43a5d82942b97e9fa
EBUILD hypothesis-6.103.1.ebuild 2522 BLAKE2B e17cd7e595def59d5b8c35d6cd2c1af05e8febc9e0484db1030a9d86cc99e41757e51b9a6789c27d080bb5d59ea74c701a88bd8f423e6bbc63ea24b2a6de636d SHA512 05df0864941735b7d4d342ddaad53bf27689063a90a3f3bf7b2e8d4521243a6c3964bfc1935d466b99c505c122c2dd342c8532f048ab8fead90d185e3f7f1c87
+EBUILD hypothesis-6.103.2.ebuild 2522 BLAKE2B e17cd7e595def59d5b8c35d6cd2c1af05e8febc9e0484db1030a9d86cc99e41757e51b9a6789c27d080bb5d59ea74c701a88bd8f423e6bbc63ea24b2a6de636d SHA512 05df0864941735b7d4d342ddaad53bf27689063a90a3f3bf7b2e8d4521243a6c3964bfc1935d466b99c505c122c2dd342c8532f048ab8fead90d185e3f7f1c87
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.103.2.ebuild b/dev-python/hypothesis/hypothesis-6.103.2.ebuild
new file mode 100644
index 000000000000..c2bf166b155f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.103.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 python3_13 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}