summaryrefslogtreecommitdiff
path: root/dev-python/hypothesis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-19 08:46:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-19 08:46:18 +0100
commit9e65a38a260a44292ceb8a0bf4fea5f0b5666826 (patch)
tree40c907f5d72cda463e42d2ee5d5434b3790e06df /dev-python/hypothesis
parentcf1a411e806b434c96329401a6ff0901ec7f0d5c (diff)
gentoo auto-resync : 19:04:2025 - 08:46:17edge
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.131.2.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 0e0c0de9b688..7109cc1c66da 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -13,5 +13,5 @@ EBUILD hypothesis-6.130.13.ebuild 2784 BLAKE2B 7d342fc269fa03fa77a4a04e4f898669b
EBUILD hypothesis-6.130.8.ebuild 2780 BLAKE2B 8ba5773e6c37903b4a7190eada0c9cfc98bd65b319db9d474e495386fab3d40c8f2ca47435b5a51ab6a3da1a11f016c54696aa6ac7e42691d9c15070e1af8075 SHA512 d9e0347c5ae910007e0f0baa1926460d81b6bc301f98b9251b16cd26ec7533640416549c9f53c254c22c270f8f5bfa940c086169261c9dfec435a2c7ddc96afc
EBUILD hypothesis-6.130.9.ebuild 2780 BLAKE2B 8ba5773e6c37903b4a7190eada0c9cfc98bd65b319db9d474e495386fab3d40c8f2ca47435b5a51ab6a3da1a11f016c54696aa6ac7e42691d9c15070e1af8075 SHA512 d9e0347c5ae910007e0f0baa1926460d81b6bc301f98b9251b16cd26ec7533640416549c9f53c254c22c270f8f5bfa940c086169261c9dfec435a2c7ddc96afc
EBUILD hypothesis-6.131.0.ebuild 2784 BLAKE2B 7d342fc269fa03fa77a4a04e4f898669b5de3962582797365abdc29d9dd62c50b36015900c90ea5abe93d6d9888f2fe81a74fa9a86c79886356164f67eca3a72 SHA512 7f36aacd94105d04170f3d7bfe4e20808f97efdb666a25bc74691dd060f43abce58fbe16e9b423e15adaa32aaf3c5924c42d6f295c2df9af3a92c68c033c7362
-EBUILD hypothesis-6.131.2.ebuild 2784 BLAKE2B 7d342fc269fa03fa77a4a04e4f898669b5de3962582797365abdc29d9dd62c50b36015900c90ea5abe93d6d9888f2fe81a74fa9a86c79886356164f67eca3a72 SHA512 7f36aacd94105d04170f3d7bfe4e20808f97efdb666a25bc74691dd060f43abce58fbe16e9b423e15adaa32aaf3c5924c42d6f295c2df9af3a92c68c033c7362
+EBUILD hypothesis-6.131.2.ebuild 2993 BLAKE2B 0d5113a5562a1d9665292002557a92783bfae14b7fbfd92152d07fa40e093456eaed979220557ec428c055082babecf0e3dd505789b605761f629eb06ff594ea SHA512 94ed63673d6997432a55c9c3e7aca796995de4efab7308ea29aa5a2d5768821fbf85cd988fad9d7f3689eaa2c06486944670f3fffb6b0e27326ddad4be1bacae
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.131.2.ebuild b/dev-python/hypothesis/hypothesis-6.131.2.ebuild
index ce50a91cd96c..95d849812f2d 100644
--- a/dev-python/hypothesis/hypothesis-6.131.2.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.131.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
CLI_COMPAT=( pypy3 python3_{10..13} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3_11 )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3_11 python3_13t )
PYTHON_REQ_USE="threads(+),sqlite"
inherit distutils-r1 optfeature
@@ -69,6 +69,12 @@ python_test() {
hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
)
;;
+ python3.13t)
+ EPYTEST_DESELECT+=(
+ # TODO: missing warning
+ 'hypothesis-python/tests/cover/test_random_module.py::test_passing_referenced_instance_within_function_scope_warns'
+ )
+ ;&
python3.1[23]*)
EPYTEST_DESELECT+=(
# TODO