summaryrefslogtreecommitdiff
path: root/dev-python/hyperlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/hyperlink
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/Manifest3
-rw-r--r--dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild27
-rw-r--r--dev-python/hyperlink/hyperlink-21.0.0.ebuild4
3 files changed, 31 insertions, 3 deletions
diff --git a/dev-python/hyperlink/Manifest b/dev-python/hyperlink/Manifest
index 3d4d3e644162..0e0e3013f02e 100644
--- a/dev-python/hyperlink/Manifest
+++ b/dev-python/hyperlink/Manifest
@@ -1,3 +1,4 @@
DIST hyperlink-21.0.0.tar.gz 140743 BLAKE2B d432692172dc5cbb4f7cc1dbbfaf87871f0d9b2519334d112841abf8d958232516249472611e986b20e6fd298f5013db38f214fa332e1b121bd80a420b4cc614 SHA512 9e0e9273dde1b0a41329a74fbb26c4f327b87f387ee64b9a2ab641ca5cc8b9ea0516884415e9adf1d4880ae9c053a5cba2c550fc508bb56fddb44a543d5da860
-EBUILD hyperlink-21.0.0.ebuild 676 BLAKE2B a129550f00b55506f7525750a401c6d120da0f444694a785ffceacd8e371c49d88d60308f660644a570193c63582360631df3ad67208c703065d4ccdfff1bf0f SHA512 663c77ed29c3595996a07b2ae21d1484e44001269d9e926589f155c717fee05c6bd2592e0ffac84c4486d62033979ee7870e9e6d8d965981e46bd04b75b828ce
+EBUILD hyperlink-21.0.0-r1.ebuild 718 BLAKE2B 9f6e6039c0a6956e7eafb2a795f6ceac022ff6169f6819ee5f803f35f6c288b728dc4040cbdae0606482e2ddee8c92a8e03cf7d34dc564c8fc245912f86944be SHA512 5845bb283e9a67daf95c2c2dc6035fd030d81b449dad10b31931626cd05358f9cf600b7ab5511ca369f0d51ddc20f0ef7fa38f3271370083ea54d3b07d9f739e
+EBUILD hyperlink-21.0.0.ebuild 682 BLAKE2B b10896caf2c21948c8eb32f9f0cce568d3dc33fde71338ff507c73fa046bde5fc681c0ac1604a487d868a3378b72b43887145f5020342b6cf7b9da72b6ca3781 SHA512 ff89f408c016619fa851618f8614ab6c3decf3628cc7416d4bae97b58138e2a960110fe7081307337ec9cb65b6eefaeaf032c1371b938bb373966c1814fa76dc
MISC metadata.xml 759 BLAKE2B db5e285020d61838ec66ed968fd1dd418ff9b10d01f7f7ed67503f9956c333d164c5c95786c5c6e845e2757c2047e44b522fb38ad2d6bad6fc4a18b04d9ec206 SHA512 c531e401294e3ddc5834fd8f7842edeff80ea3ce2126716b90bfeecfdbb2a4c573befef01a7aaf8bf27e9707b69ad665347eae7002a98745b72836a213be0b94
diff --git a/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild b/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild
new file mode 100644
index 000000000000..65b9f34238bf
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # suppresses hypothesis health checks
+ local -x CI=1
+ epytest
+}
diff --git a/dev-python/hyperlink/hyperlink-21.0.0.ebuild b/dev-python/hyperlink/hyperlink-21.0.0.ebuild
index 20047351abe9..45ffb2446234 100644
--- a/dev-python/hyperlink/hyperlink-21.0.0.ebuild
+++ b/dev-python/hyperlink/hyperlink-21.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A featureful, correct URL for Python"