summaryrefslogtreecommitdiff
path: root/dev-python/hyperlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/hyperlink
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/Manifest2
-rw-r--r--dev-python/hyperlink/hyperlink-21.0.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/hyperlink/Manifest b/dev-python/hyperlink/Manifest
index a4b3042353f2..d331204e6ed5 100644
--- a/dev-python/hyperlink/Manifest
+++ b/dev-python/hyperlink/Manifest
@@ -1,3 +1,5 @@
DIST hyperlink-20.0.1.tar.gz 140291 BLAKE2B ee8c741d4cb87e4a577e1c9a45614f5f47e086f27b60a75897b66684ab5927da73ccaba47b16b770f0277a52351cc732cf74762e29c83644c220ed59c67a18d0 SHA512 f935c09d35baf8a8a3c8d4dc6aaf64135d13dda4636187f5d47f3fe4de675498efa29cd93d802c0912db2fa371d0e58213767b1c3c42e5a14bb837ea96a72193
+DIST hyperlink-21.0.0.tar.gz 140743 BLAKE2B d432692172dc5cbb4f7cc1dbbfaf87871f0d9b2519334d112841abf8d958232516249472611e986b20e6fd298f5013db38f214fa332e1b121bd80a420b4cc614 SHA512 9e0e9273dde1b0a41329a74fbb26c4f327b87f387ee64b9a2ab641ca5cc8b9ea0516884415e9adf1d4880ae9c053a5cba2c550fc508bb56fddb44a543d5da860
EBUILD hyperlink-20.0.1.ebuild 679 BLAKE2B 80b69f545a6f258d0eb070292bc5fe40e798d5ee37864bf82edbe49b69c3be88eda2e7155c5e3cf0568c5a45cc6b8d1d24f5648ae92e6d401aba6e97f83333bb SHA512 3a6873bb96a52c491da05afc75bab9444333d0deb97e0d8b3985a8600834b85463fc5bfd2235794bfa91b65714ec3890d29be7cf6fd1d49e63583753c3922a42
+EBUILD hyperlink-21.0.0.ebuild 685 BLAKE2B d1cb797a8afc5c016b8c4a896bf833bed8223a3dd7326a5df9bf4ef17c5b3ece086284e5bfbf73854ef841060ca8a71c94499a3b3cb6bb78624928498f15f99a SHA512 646e39d2d2b98136c221c19027b90b6f336f69bd0b25fc295c87005fc675c3a255a0b6e502485d036f82cb2fb0b3266a9d348410f01df60b219bcea5aae20a0d
MISC metadata.xml 758 BLAKE2B 36fe15b27fb5bd52c60917e90c20fcf6db9e7c5eb094420cc8dab852748decbc6a0d40c15f4c0402bab1c8a014ce5346e5a55f497c7ad4fca7c2c1d9cd91c304 SHA512 ec95c17a3743643c0666c7a12aa3a2a2c91fc97a64bb21c7429e00e23d42f82897e57e8eecef2f7fe72e49238061f190a0b1e1b81d3b938051bb17a008335abc
diff --git a/dev-python/hyperlink/hyperlink-21.0.0.ebuild b/dev-python/hyperlink/hyperlink-21.0.0.ebuild
new file mode 100644
index 000000000000..48f99bd74f08
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-21.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # suppresses hypothesis health checks
+ local -x CI=1
+ distutils-r1_src_test
+}