summaryrefslogtreecommitdiff
path: root/dev-python/hypercorn/hypercorn-0.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-01 17:49:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-01 17:49:46 +0000
commitc16ac3f2fa4ccc7440fd13db1e5872a3e319f48c (patch)
tree4a3b9bbf32f7a7f613e6b67f3af294606333846a /dev-python/hypercorn/hypercorn-0.16.0.ebuild
parent94605f5ed96183fd23685900c001b8cf2047c521 (diff)
gentoo auto-resync : 01:01:2024 - 17:49:46
Diffstat (limited to 'dev-python/hypercorn/hypercorn-0.16.0.ebuild')
-rw-r--r--dev-python/hypercorn/hypercorn-0.16.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/hypercorn/hypercorn-0.16.0.ebuild b/dev-python/hypercorn/hypercorn-0.16.0.ebuild
new file mode 100644
index 000000000000..2e24cd3a010c
--- /dev/null
+++ b/dev-python/hypercorn/hypercorn-0.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A ASGI Server based on Hyper libraries and inspired by Gunicorn"
+HOMEPAGE="
+ https://github.com/pgjones/hypercorn/
+ https://pypi.org/project/Hypercorn/
+"
+SRC_URI="
+ https://github.com/pgjones/hypercorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ dev-python/h11[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.1.0[${PYTHON_USEDEP}]
+ dev-python/priority[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/taskgroup[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/wsproto-0.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--no-cov-on-fail::' pyproject.toml || die
+ distutils-r1_src_prepare
+}