summaryrefslogtreecommitdiff
path: root/dev-python/hvac
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/hvac
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/hvac')
-rw-r--r--dev-python/hvac/Manifest3
-rw-r--r--dev-python/hvac/hvac-0.2.17.ebuild29
-rw-r--r--dev-python/hvac/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/hvac/Manifest b/dev-python/hvac/Manifest
new file mode 100644
index 000000000000..5987b4cb8d1d
--- /dev/null
+++ b/dev-python/hvac/Manifest
@@ -0,0 +1,3 @@
+DIST hvac-0.2.17.tar.gz 9884 BLAKE2B ddd40e29d7666a9d41a040f55574be82f32fb27ec4b8c65c8a360bdc924a5a7e0d8a36c32d0f663871406dc8bcd315c2a64fca9d852d24d3b14b1db464b182ef SHA512 5c35cf3cc2e1e08a9ffa0f485da89725b84753822165a2d5ba0de2db616281beb12acff85d4b091234f2127df43d409001716eb95c9277503c45771d1d2be412
+EBUILD hvac-0.2.17.ebuild 686 BLAKE2B 87cef9fcd3158fe8ede2a5eba060f3928adddc8984f4cad6bbd531f8e88913cdafe37709f8781ffa7a63e2b55c919abe17b7613614f8e32424526242bde705f3 SHA512 31a82e6c2c8aa1f006da23fca241ac622dc59fdecff4062a571d848ae89dffe93a29fda3267c4381d4364182de141f7b44d8458a345d4843e9eac1d84944404e
+MISC metadata.xml 318 BLAKE2B eab978479ceda3e002d7f433c43f07c770d5a6d04ecd47562a8235f59799eb6429861c8f1d9a4ef033073473ab212d77775baf7e3cc9327f76ad46c6477f1c33 SHA512 b39506ba5cb096645fb3dff6b16f333216464806289dd293191405bf8e6008e91d89bcfe0aaadab46db10bc6257b08f9070555ed520a5144f2defd586061fc34
diff --git a/dev-python/hvac/hvac-0.2.17.ebuild b/dev-python/hvac/hvac-0.2.17.ebuild
new file mode 100644
index 000000000000..6932511b0499
--- /dev/null
+++ b/dev-python/hvac/hvac-0.2.17.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2/3 client for HashiCorp Vault"
+HOMEPAGE="https://github.com/ianunruh/hvac"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="<dev-python/pyhcl-0.3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ app-admin/vault
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # need running vault
+
+python_test() {
+ nosetests -v || die
+}
diff --git a/dev-python/hvac/metadata.xml b/dev-python/hvac/metadata.xml
new file mode 100644
index 000000000000..29195172efab
--- /dev/null
+++ b/dev-python/hvac/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ianunruh/hvac</remote-id>
+ </upstream>
+</pkgmetadata>