summaryrefslogtreecommitdiff
path: root/dev-python/hvac/hvac-0.2.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/hvac/hvac-0.2.17.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/hvac/hvac-0.2.17.ebuild')
-rw-r--r--dev-python/hvac/hvac-0.2.17.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hvac/hvac-0.2.17.ebuild b/dev-python/hvac/hvac-0.2.17.ebuild
new file mode 100644
index 000000000000..b156b861035c
--- /dev/null
+++ b/dev-python/hvac/hvac-0.2.17.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2/3 client for HashiCorp Vault"
+HOMEPAGE="https://github.com/ianunruh/hvac"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="<dev-python/pyhcl-0.3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ app-admin/vault
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # need running vault
+
+python_test() {
+ nosetests -v || die
+}