summaryrefslogtreecommitdiff
path: root/dev-python/humanize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
commitc74abf990d32765245eeb94b36ad4af642cae8c0 (patch)
treeb700660e782342b531312e3855b949f5b2fbbc60 /dev-python/humanize
parent5a21cec0c36dba03507dcbd5e8ab6698d00b39bf (diff)
gentoo auto-resync : 17:08:2023 - 15:32:39
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest2
-rw-r--r--dev-python/humanize/humanize-4.8.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 66b92be86eda..7d3547d8fcdc 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,3 +1,5 @@
DIST humanize-4.7.0.tar.gz 72028 BLAKE2B 86926d24ca20168cd1f5dc37aad38a53be59ab786bd02c25ba54930854b4459949bfa988f3135c97f15cc51b2b9fcdcb32f85a668ddbb4af2b571d974523cc12 SHA512 2454c4b7dec6868a1626af560e4f87d7bfb8eac6a919c7d7c03254723ec58494f104f7fa365c64cb4cecf50cd6d498b4201f9fda6ac1f6d2980e9e54eebde738
+DIST humanize-4.8.0.tar.gz 72894 BLAKE2B 905c9499c9e57959cda3c66d98f4ddb1ddd04278ad53e1d139ca5ff65cf84d526ec7ba5766a6fffecda7e4f31ce9a6b1e59c377b7f37bad3c929ea3bcc77d44f SHA512 2372b9518c6037bbd6bda341cce7f04e6acd0f68c1fe7218e3201477ce12324f6b98efca2bc7024222bfcc222840cd5a6a04649269c86ded7bb81b30d1602cc9
EBUILD humanize-4.7.0.ebuild 534 BLAKE2B 786b5246753af04935bcaeb0a516073b2b9f4e1fef59e0ad68e6f5a7a276a47e3ae5c3b1634260d3db56bf68849ebce22bfc388cdfc5eadb749a28add48abec4 SHA512 05da0d3ea7945248b1778aa5dddf9852a260fad4bcc07d31fdafde05b68f8a08059b8b64f6b21386789efa2e6916f95a0ec78b5f877617b89c3081ab84703a36
+EBUILD humanize-4.8.0.ebuild 536 BLAKE2B 60fc046d0868f0e927ee77ef9332f410787692f550e8f2be6543bd937bade89ea3f657cf5e6650892d21e978975472d973719c4f5e769b9e5bfd6a60ba11e1bf SHA512 a3139d25a1495a091e1b47dc6877482355e0e6efded3ba71dcd1199bc1cf029b42a633612e0dd47d710fd6e3a125bee965703df0e362118472f7c3725de85018
MISC metadata.xml 506 BLAKE2B c00c304481f8bd5d2309a1fa72a19bd8405d2f8d55e68a9e688435dec5410db728537362d6fc090f448738fa462ad62d03cfdb82fda8702b91aced4ecd6c05d5 SHA512 71905cfb331f60723b2b3dc02b1a5cbc2712ea9a411692d8ce12e62ea90a4ebef41bb4806b90f9bc0706d8dfb6a3ebb69d23ef16f0177eaddcfbdf07612d8614
diff --git a/dev-python/humanize/humanize-4.8.0.ebuild b/dev-python/humanize/humanize-4.8.0.ebuild
new file mode 100644
index 000000000000..681e01638c1b
--- /dev/null
+++ b/dev-python/humanize/humanize-4.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest