summaryrefslogtreecommitdiff
path: root/dev-python/humanize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-09 12:24:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-09 12:24:59 +0100
commitc218398bbbe70a616790cf146c28c1066b9284bf (patch)
treea598e8c85afbc52bb7eca18ae415ef4971e65c8f /dev-python/humanize
parenta5442e2318cb4df55867389654e322dbac82067e (diff)
gentoo auto-resync : 09:07:2024 - 12:24:58
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest2
-rw-r--r--dev-python/humanize/humanize-4.10.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 193830a756d1..12b47e9b85a2 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,3 +1,5 @@
+DIST humanize-4.10.0.tar.gz 79192 BLAKE2B 398fe1eb3b39cfc93096f7e12f057959f3e336721fe05be4bfe0bf16d3470a04a33b978c6e4ffb73c58bfb1032f9ec48b29397ef51073aa881b036427e73eb10 SHA512 973fe7aecffcc7c9b56426b5a143402a97833122e63362115ae50318c909188bbe872fbfdfaa3015298ecd44c6ebc4223d9abd202c47622066b730908a6dda44
DIST humanize-4.9.0.tar.gz 78465 BLAKE2B bb13199f7ed9b833891e1e5f166dce33e167224c5fb75ab33130a551680e802aa347f5e19cd1162caa79917af6e0acbbb36226d5051a9d4eef07bc554ba0e19e SHA512 64238f6717302cec4cac853fd2813647132eb4f6cd73cc61fd43346577cd42bbc2cf5a7345910393cd9a4e9c2b5e949a50c6259b0bd8254a05e08d0d8d70a5d5
+EBUILD humanize-4.10.0.ebuild 635 BLAKE2B a4938f8e24826a8469dd21c91a83f6624763c978ea5acd21dd1bd6ae3ce7354d88807c8cdafe3c0179c6381729a266c77f1ea50d7214cda6a71643d67ada6f68 SHA512 262ac5eca5df2eb542c9bd6482b5e3d589155311560ae2ac84c413a2a854ec403f2835a4439b5b865e2b9024d55073285b2bcb7d838860f1b1e433be67a50ec8
EBUILD humanize-4.9.0.ebuild 540 BLAKE2B 9b0413ac16b710a166a63639bd084f00d79f82a8f66c67e5d685e290a7de3c7f86ac6cda4530c27e0a609d1ece20da136888c72d0c035abc6f4d8f39ff85a0db SHA512 581c241d937e24635fd7a007a7211b2b808bc5a4319ee920f5c26b3a8179fb190d18db1938d6111153c7fcf8d903582897b0587e8f4fac133c6bcc0fc6025f7f
MISC metadata.xml 506 BLAKE2B c00c304481f8bd5d2309a1fa72a19bd8405d2f8d55e68a9e688435dec5410db728537362d6fc090f448738fa462ad62d03cfdb82fda8702b91aced4ecd6c05d5 SHA512 71905cfb331f60723b2b3dc02b1a5cbc2712ea9a411692d8ce12e62ea90a4ebef41bb4806b90f9bc0706d8dfb6a3ebb69d23ef16f0177eaddcfbdf07612d8614
diff --git a/dev-python/humanize/humanize-4.10.0.ebuild b/dev-python/humanize/humanize-4.10.0.ebuild
new file mode 100644
index 000000000000..5d18d9873a5a
--- /dev/null
+++ b/dev-python/humanize/humanize-4.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/coverage/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}