summaryrefslogtreecommitdiff
path: root/dev-python/humanize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/humanize
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest2
-rw-r--r--dev-python/humanize/humanize-3.2.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 16ea7b51f77a..5bac5ded31e0 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,3 +1,5 @@
DIST humanize-3.1.0.tar.gz 54352 BLAKE2B 0e25f4f7f01244f5b24a33c54546c2b2d82e0e069d2cabbe67ff0e5f8e2bc9d3aa2eb7f4d63d4a01dc8ff4ddcfee030b33015ede00d769dfafccb6c2af95171a SHA512 71cb2766a791481f4dc5e02b77357e8e4e7332e533ee055a207cf145f2b2f9041c5bc4ce25f061f0cc1498f37edbc6243f63b888a322c0cf19e5216e120542dc
+DIST humanize-3.2.0.tar.gz 53976 BLAKE2B 2e9347418ffa103c6a66583136aa0c79bce669b48fcbc01bf482ba16659af14d4b4a88e78167e8013a8ede6467ed7b7f5eea8f46ed4234294a79b0c63fabd17c SHA512 448919e762e0ecc95f5a7158e0dd8bc028d173ee236be8e15fd0283741af037af1bcdc671ed83b0c16c1998dc0a70debf11cb1c349085530e458bc7aa2f6dde4
EBUILD humanize-3.1.0.ebuild 693 BLAKE2B b8451a66d9f40936d328a924642399b20dae17bb9ebc9f948b5a72e0229dd2cc242573f4c101200d03aa4a49617dd92b95b7263bc4f508a2ebd43acf05a96b8d SHA512 31bb2793727c00e3e18f69893394535403c7a6841759022e2f15cd508ff8ef57e4600725b3317f72145e570ec215eb61da46c77f313e7b6947d6b842301d142a
+EBUILD humanize-3.2.0.ebuild 706 BLAKE2B ea1f49746655d50b60c5a276328d5a8665e7530c5d0afeb3c1f716b8e62602a05aeeb881725a1599369cd2a9ec60018d3417e82004ad54ffa9e2d21a7b0c6b5c SHA512 3af0ec7f150aa79bdc208fe92fce0337e34c23fcbab0a3743a537c2a606c7997f36b7a3d37c3448058e1638a64c9ec16f7f4d29aecc0c66f1e26a5d1aff3d991
MISC metadata.xml 561 BLAKE2B a7919d3646edc6a4e7c2e13d74b1ae4eb18e16c41d33f27adb2841e80ab12e5d85f42bedab668c1096740e7ed1323e5accac1ba45a78290f0979c55e39c9d682 SHA512 b31a4947368fcbfb0edf93b48f843c49d5209820cf9da1a8aeb8666ab4fffebac765ca4aeb3cf2523837fcfc9c21d858cecaed65002ac23bb9d946a8c818f113
diff --git a/dev-python/humanize/humanize-3.2.0.ebuild b/dev-python/humanize/humanize-3.2.0.ebuild
new file mode 100644
index 000000000000..fa1c2e7585b3
--- /dev/null
+++ b/dev-python/humanize/humanize-3.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # The package uses pkg_resources to determine its version
+ distutils_install_for_testing --via-root
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}