summaryrefslogtreecommitdiff
path: root/dev-python/humanize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-30 08:57:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-30 08:57:14 +0000
commit552fc3ba95eab5c2c1a8b2b55ab432a1019739a0 (patch)
treeadad36adc624e114d5b985e392ac40a7b94d8ac6 /dev-python/humanize
parent61966498b463d88a09132a9a22c68c0c37159e41 (diff)
gentoo auto-resync : 30:01:2023 - 08:57:13
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest2
-rw-r--r--dev-python/humanize/humanize-4.5.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index e0412ca5036e..1bd4db7d622c 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,3 +1,5 @@
DIST humanize-4.4.0.tar.gz 78519 BLAKE2B f61b654e201995479ace22b5aac106b08304ed9212cf5c6c7f87731d861c42c5e0243f7bb0b7f2c29b870421fa81fba0c36e4ead90ff90f207bc984286ac119a SHA512 bbbd386d9af82d9db0f2edc4653928654203c4239419232abfc15c51ccd865b355366549c46651e1291d4222ca8b2a297ffc0fce3cc32be4ae2f904ae308a8e4
+DIST humanize-4.5.0.tar.gz 82709 BLAKE2B 97173e7b3dc7b35ff8dbb5b985153c35dd49332d733464ece7eeb00a23c2f7f2660fde9263b416dcd83f11e8ec0a578a4fa1648c6955b8dbc35540a2606d0d38 SHA512 7f045f6cf7c6c5cd37ecd1a3d5c6ed40d3e64e14d0718b07938c01ce3722e0487cbc90752840b644b8befff5c7db16090d510eabeb59c4dcf5306eadea005019
EBUILD humanize-4.4.0.ebuild 586 BLAKE2B f325ee5e78d6d5247571e0e4902a9ccb46f764389e0a5f8a39193fefa5f09f44a810c4ab8b925fcee520cab5ab02469b4f8f734c40574c79a80d63c21e17a4ea SHA512 bf199b8f234054c042a9bd0bdcd335bc0a9ca072ee9557219489d56ac9b328f3e075ec7b27f87cce70a4d5568f79871f8ae126018cd9943b2e8f1ba51913bdcf
+EBUILD humanize-4.5.0.ebuild 594 BLAKE2B d744a9f4a8239a4ee6212d5f97c8b1e1bffec1b40aacce15e59a4beb345d353b5296a22d03bd1bb9641397d28b6012a2ee0b6c70eb3ea36cfe7cf48eddd449c1 SHA512 1f6f5c313fd8f3e41fa4115861d03200e7faee9c9600777875fa558ea4c7f5bba6797e69c8da522967f0b4a90e77ede2780e053ff6cddbbe6873f27c8398d728
MISC metadata.xml 506 BLAKE2B c00c304481f8bd5d2309a1fa72a19bd8405d2f8d55e68a9e688435dec5410db728537362d6fc090f448738fa462ad62d03cfdb82fda8702b91aced4ecd6c05d5 SHA512 71905cfb331f60723b2b3dc02b1a5cbc2712ea9a411692d8ce12e62ea90a4ebef41bb4806b90f9bc0706d8dfb6a3ebb69d23ef16f0177eaddcfbdf07612d8614
diff --git a/dev-python/humanize/humanize-4.5.0.ebuild b/dev-python/humanize/humanize-4.5.0.ebuild
new file mode 100644
index 000000000000..79adf26cf1e9
--- /dev/null
+++ b/dev-python/humanize/humanize-4.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest