summaryrefslogtreecommitdiff
path: root/dev-python/humanfriendly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/humanfriendly
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest2
-rw-r--r--dev-python/humanfriendly/humanfriendly-8.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 6af4892a41e8..db0d17b1435e 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,3 +1,5 @@
DIST humanfriendly-4.18.tar.gz 345853 BLAKE2B 9b03ea0679f787e216ee78efe8feb77f83562998813718845f4d21b7ce3f42cadff0e80b96f02da3cf6dc7f35cb0714f746940cf2ac0ec8e8981377989650c8a SHA512 01c7ee50d35154fe0b7ad39662ca6ff2dcd3e0f2a2eacc62f0184102c9db1c0fd99257273982aff56710b4e59024e8c20ee77ddd10c68e427c077ed4ca7e0022
+DIST humanfriendly-8.2.tar.gz 358747 BLAKE2B bc5824e94ea94df6ee93ea44d273ccb856f50b69e52ae6293afaedf06c9f00c67e064f0c85edd88be9954bb258334b1b9af4ab88efc5b352f3efe8d322fc55c1 SHA512 123d8592e6613a70421740648bb8998733b118927a0bd6182af848612e46eec8e35cae95168219c9b7672bed8e18e1c4a493a80248eabe47f8a4cb1813c8b591
EBUILD humanfriendly-4.18.ebuild 807 BLAKE2B 0c03c4fc21aa1909fdd84cb53b82ff0ab27d020d38a40ffdfd5d559ae79284dbaec8c09b18106f25bbc79ea9f4024a1af181363edb2e58f3c346412899ba49ca SHA512 7f33d3e52c193d09ff1d58ece09f428d9ae75619ed0aeb9b17b902b0181adda126259fd0e51b444c5186a9d1012ed445db5700aec97ec015ead7327f86259dfd
+EBUILD humanfriendly-8.2.ebuild 896 BLAKE2B 5b351de246dce297e9aee2ba5149f893c3884446758b618570f8c053b46fa0f0dcf5b0f15082f5b1e52d93aa6ea9786281a566fc365bf865decda7e9a5ac3a5c SHA512 fc28d50dacacd1a48584e33434daed2c781ddb17db6b33b7a14b167468cd482355777f045f264386d3be191b8bb431a9c3fd30f3424710ad424f33c21bf371ab
MISC metadata.xml 326 BLAKE2B 5db2fb344393d914a42d1b9b256782d2e8286daa33ff4b8687d23e613ae8d168052dc310cab48ef0c49c524d3b5115d2a17cbede518fe93e944c0067c94f9c7b SHA512 1338df242248b37b4d016d8f9a31ffa004eed60a9122ed9ec8f94103271b3136b698a613c0f7c91411f43d96b136777e0ffe808c250f9ece3d29922312457f47
diff --git a/dev-python/humanfriendly/humanfriendly-8.2.ebuild b/dev-python/humanfriendly/humanfriendly-8.2.ebuild
new file mode 100644
index 000000000000..a918f9d2b315
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-8.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly
+ https://github.com/xolox/python-humanfriendly
+ https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}