summaryrefslogtreecommitdiff
path: root/dev-python/humanfriendly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/humanfriendly
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest2
-rw-r--r--dev-python/humanfriendly/humanfriendly-9.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index c428c814ebe7..05f6e6a95b11 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,5 +1,7 @@
DIST humanfriendly-8.2.tar.gz 358747 BLAKE2B bc5824e94ea94df6ee93ea44d273ccb856f50b69e52ae6293afaedf06c9f00c67e064f0c85edd88be9954bb258334b1b9af4ab88efc5b352f3efe8d322fc55c1 SHA512 123d8592e6613a70421740648bb8998733b118927a0bd6182af848612e46eec8e35cae95168219c9b7672bed8e18e1c4a493a80248eabe47f8a4cb1813c8b591
DIST humanfriendly-9.1.tar.gz 359616 BLAKE2B c67ca9498ff4a0dac237c8f1c81ae88882a7ab162e2cfd663cd50a066dbcfe045424bdf4dcc1df473f5fc41f0c1b8c0f2aca9883aa21915281618ba332c579a3 SHA512 859a9ff01abe0671a23a63e73c9c09c0f92151e96ec38dd5695c75f99fa436e186835cb8a16f59b82d5216b9c427ea0abd419b470b067f8032fe984776f02a8f
+DIST humanfriendly-9.2.tar.gz 360080 BLAKE2B 39aa17315a87938468f2d6e94b0287f07864476c4179c40504126c65f7042c96113a9d60f481a6a03913ae5c8cfde2c87476e0d403c964aa65abceb0f55633f1 SHA512 2abb8d7d4dfb84d625e82f3475bea5045c32f548a45999dca97d39e5bc0cd704a9ab45e0b6b87c0d419b447680a3e71e2d9c8cb14ba19117c7ac9b2f56297f00
EBUILD humanfriendly-8.2.ebuild 898 BLAKE2B 7685970c808a965f3cc87d1d457110b1eba2c6707647299195ac6b8589d4baf1e48a497ad4717b2c3209028157a68211dd413361603eef4b1c39deddff0bd320 SHA512 2c814d9819ea87316a9eb16ad020eb8db578ea715a6927a1840ed07e8b603b083fe8f09cd47637699b10298d43dc63ad9954630c5914e1e7645268ffb80793f6
EBUILD humanfriendly-9.1.ebuild 897 BLAKE2B aa4f3a4dc7956bbf09e4e3c44e9a697a94e9f9e216440d36c780658dd729a211881dde7cd8a84b602924393605e4b7facfabf0e8e975e0b0e4092115bf8aca94 SHA512 5c68cd3fa187c9107ba02c5120a2af7d8bb8d576472ac518f2098286c4b4525310acee68113a60f4de4a439681582da3efa9bd2dbcda889bcc1aea0233ba680f
+EBUILD humanfriendly-9.2.ebuild 842 BLAKE2B aca0ad4add5f23c0b0844630668f86489a25b6e6c9e71313e5cc5c7bbd00006addf95401ca4082805274133dbf3cc1d2182433f3ef3e476565bd4960d8b5aab3 SHA512 d033af056ccddbcc7da2be4fa26e8f4d1acc4618c8663fd4074206372b18664d8c30a3adf666137ca8a4f94feb808fb8f2e903977ea94e18c322ba0e03541fb2
MISC metadata.xml 406 BLAKE2B 974edaa1c5189ede8c81989c21436b45d53cf5d92e1b2b49a6731f68d098410966685f5184eda0e55191c441390a8f3f9869ae945425655b559dae160d99ba19 SHA512 86b4ff000469fd0edd3c089b725d3e2144be2f56fb5f2ccc3f4e936a5a12c8c45b2a4ac8cc1857c8c14d54fcc04717e2bd7effc7ff6d728f9033d41856095096
diff --git a/dev-python/humanfriendly/humanfriendly-9.2.ebuild b/dev-python/humanfriendly/humanfriendly-9.2.ebuild
new file mode 100644
index 000000000000..e7c4b6fdf3fc
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly/
+ https://github.com/xolox/python-humanfriendly/
+ https://humanfriendly.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ >=dev-python/coloredlogs-15.0.1[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ epytest humanfriendly/tests.py
+}