summaryrefslogtreecommitdiff
path: root/dev-python/humanfriendly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
commit867ef65cd897014478ed65034b1ac3f139289a77 (patch)
tree3af9d9e893bca02bb644786f42dfaf2678d6908d /dev-python/humanfriendly
parentf077c725ef746943ec7902350b30ff569f5995ba (diff)
gentoo auto-resync : 08:11:2022 - 15:24:16
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest1
-rw-r--r--dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 138c3b12385a..26fd66d80b91 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1,3 +1,4 @@
DIST humanfriendly-10.0.tar.gz 360702 BLAKE2B 6db7f2f11bafcdc087c078eae6123046610594b17899678e445baa18c25b2210cc1d84363d858ab7c57fce6d6b7a189be69dea08c1891d3f5b11ff9900c9bef9 SHA512 496700bcea1dabf003c938558bf807fabb41b71192f69622979dd9e243dda9b4b06c5ac8f65cef217df85ebadf99099dc22b50d63216791a569be11081d267d6
+EBUILD humanfriendly-10.0-r1.ebuild 993 BLAKE2B d9f51863a7f11349c043a519c45677646f05988a31696a3436f734dc8de8ae54d0d93cbd3749d033625f4f4a80d4628601d939d365d4f321094caaa7dcd6c30c SHA512 9caf8e5d7ac8961902080c16aeba082301d5bf0041fef3afafa48af7fcb850966666c25cff09b5f6954c12ea5f98eb8e578d0c57af701a23c5c2b1fbe6bf0201
EBUILD humanfriendly-10.0.ebuild 843 BLAKE2B 859b2c5a28fc7cad99077df64e66fcdd60455778f7305038502dea8ac6fb22c2d58b6b93eb42f0e759c6dba11cb42573692aad42f6e7364579f85495bf82d2ee SHA512 0c9d22a5bb5070e2a01596e53ba2191938e2d4c38f63a5eec324e36ce60f2c52b7af51760042d31d4968454f578be6b25312c89ecd15ad9391b3395c80948928
MISC metadata.xml 407 BLAKE2B 7d2146a2514b6d9afb68e6ba104acff4a38c650f678e930242659a96028d734dba0c69deaf3cca06225a2b9324f9e4639ec5e6324a2b845468bc5e180f2ba061 SHA512 57e8f1b2de1594bd97fca291b778b92ed09a26b61f97ca7988fda2b1efff181394bbd7ae20a0a94066c7cf58da553ef4881cff2b79207577c710780b9800baaf
diff --git a/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild b/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild
new file mode 100644
index 000000000000..c39fcb139268
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-10.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly/
+ https://github.com/xolox/python-humanfriendly/
+ https://humanfriendly.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+# This is completely broken
+# AttributeError: module 'humanfriendly.tests' has no attribute 'connect'
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ >=dev-python/coloredlogs-15.0.1[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ epytest humanfriendly/tests.py
+}