summaryrefslogtreecommitdiff
path: root/dev-python/humanfriendly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/humanfriendly
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/humanfriendly')
-rw-r--r--dev-python/humanfriendly/Manifest3
-rw-r--r--dev-python/humanfriendly/humanfriendly-2.4.ebuild33
-rw-r--r--dev-python/humanfriendly/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
new file mode 100644
index 000000000000..1486abe0a1cf
--- /dev/null
+++ b/dev-python/humanfriendly/Manifest
@@ -0,0 +1,3 @@
+DIST humanfriendly-2.4.tar.gz 51037 BLAKE2B 3775505a8a32c19b921d6f397951dc61da9d5c4d3c8313a519cb350d4dcee09797b4d3412c7084d6a722397e675be345af946e132058e57d77e426d3ca2a3230 SHA512 e35017c6be9d80ac5e3465836aae4f5b1ea4358224e250c7c1b7e3a93c2764832382e0ec24ea54e1d656fd8874c12b23ffc535440870b55a532800c5953cc676
+EBUILD humanfriendly-2.4.ebuild 799 BLAKE2B 5653ffe8d0eabaead6577e217d86d4580ba89df528d83f2f0f500b32a1826d05f65d97a4dc3f9c5bb3a0601e2ba5cff23917a637ab0e50e40bd122d971026624 SHA512 38863a6b458ce5191e6d8e199172d7004a51c42aa240fb5f87d8872f8372a3d9e24358ecc95be4faa7d2d66576e668ec7dc8d31ae39eea30b25cd2f391e1c54f
+MISC metadata.xml 326 BLAKE2B 5db2fb344393d914a42d1b9b256782d2e8286daa33ff4b8687d23e613ae8d168052dc310cab48ef0c49c524d3b5115d2a17cbede518fe93e944c0067c94f9c7b SHA512 1338df242248b37b4d016d8f9a31ffa004eed60a9122ed9ec8f94103271b3136b698a613c0f7c91411f43d96b136777e0ffe808c250f9ece3d29922312457f47
diff --git a/dev-python/humanfriendly/humanfriendly-2.4.ebuild b/dev-python/humanfriendly/humanfriendly-2.4.ebuild
new file mode 100644
index 000000000000..f8de554ce4ed
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.org/project/humanfriendly/ https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/monotonic[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/capturer-2.1[${PYTHON_USEDEP}]
+ >=dev-python/coloredlogs-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ "
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/humanfriendly/metadata.xml b/dev-python/humanfriendly/metadata.xml
new file mode 100644
index 000000000000..10691287e903
--- /dev/null
+++ b/dev-python/humanfriendly/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">humanfriendly</remote-id>
+ </upstream>
+</pkgmetadata>