summaryrefslogtreecommitdiff
path: root/dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild')
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild
new file mode 100644
index 000000000000..cea09d4633ef
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.4.18.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="https://github.com/Salamek/huawei-lte-api"
+SRC_URI="https://github.com/Salamek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/dicttoxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # https://github.com/Salamek/huawei-lte-api/issues/86
+ sed "s:'pytest-runner'::" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest