summaryrefslogtreecommitdiff
path: root/dev-python/httpx/httpx-0.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/httpx/httpx-0.19.0.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/httpx/httpx-0.19.0.ebuild')
-rw-r--r--dev-python/httpx/httpx-0.19.0.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/dev-python/httpx/httpx-0.19.0.ebuild b/dev-python/httpx/httpx-0.19.0.ebuild
index f5ee2bdc0bc9..e739250c670f 100644
--- a/dev-python/httpx/httpx-0.19.0.ebuild
+++ b/dev-python/httpx/httpx-0.19.0.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ppc ppc64 sparc x86"
RDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
@@ -41,19 +41,20 @@ BDEPEND="
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ # known to fail, unimportant test
+ "tests/test_decoders.py::test_text_decoder[data3-iso-8859-1]"
+ tests/models/test_responses.py::test_response_no_charset_with_iso_8859_1_content
+)
+
python_prepare_all() {
+ # increase timeout for slower systems
+ sed -e 's/pool=/&10*/' -i tests/test_timeouts.py || die
# trio does not support py3.10
- sed -i '/^import trio/d' tests/concurrency.py || die
- sed -i '/pytest.param("trio", marks=pytest.mark.trio)/d' tests/conftest.py || die
+ sed -e '/^import trio/d' -i tests/concurrency.py || die
+ sed -e '/pytest.param("trio", marks=pytest.mark.trio)/d' -i tests/conftest.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- local deselect=(
- # Internet
- tests/client/test_proxies.py::test_async_proxy_close
- tests/client/test_proxies.py::test_sync_proxy_close
- )
-
- epytest ${deselect[@]/#/--deselect }
-}