summaryrefslogtreecommitdiff
path: root/dev-python/httpx-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-14 22:48:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-14 22:48:30 +0100
commitea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (patch)
tree4b5a746c80bd7aacbe83448c66643e9dc4dcc105 /dev-python/httpx-socks
parentcdb999af22d9aa464bfd480fc9f5ebda71fc89e2 (diff)
gentoo auto-resync : 14:09:2023 - 22:48:30
Diffstat (limited to 'dev-python/httpx-socks')
-rw-r--r--dev-python/httpx-socks/Manifest2
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.7.8.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index 1bfeb0124e10..9d968f117d82 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1,3 +1,5 @@
DIST httpx-socks-0.7.7.gh.tar.gz 15127 BLAKE2B 7cdc74de0860edfab5e7bf3ef00312fe813d322c25800fc62985cfe45cc2d16ff2fe03d8b24779e6ba1a065797c8e56a61e025da263d4437e5f04e13fba3f7a7 SHA512 70cccf16245fa364a5f91718e708d67c3ce8fc4bf5bf37a43c620b76b6b294df6d5dc971c1fd69bd3f75d5543b87a0d7eb2f3348492f807517224b0f7e62fe1f
+DIST httpx-socks-0.7.8.gh.tar.gz 15129 BLAKE2B 8793e67efad2dc4a38f240d9b8710fe392545b20698c569ad00df31d9aa0a144426ebf714bca5960ce2ba73161eb361c1289173212752e712a0bfa022edb7a24 SHA512 f7d6877ee941c6bb4db84995d7debf36f7c793bd598f26281614a7988cc335ca6280c70b6b3a6450a2af358a011cdfc52255e7b1f34ac2e9c7bc93be6a945054
EBUILD httpx-socks-0.7.7.ebuild 1195 BLAKE2B 3df614f7bbd3c6454008a901d790e009b13d680c175ed3f32d2301e965cd3441c6d6d26a9e39b745f20fa228db0872fef60372fb9f5d4dd6a01cd437826ccb66 SHA512 9d1d901870f232460f52863c0d66ddc0c749c5e55a51a6262a317d6e9bbab82a663497536932f6062d7dcda857581ebdbc0fce985f64e5c48e4f554f684cb6a9
+EBUILD httpx-socks-0.7.8.ebuild 1203 BLAKE2B 58f73ff22ecc6635201286dd32e8fcd53bb1d3d85becd61828a72da1f3902deb8ca67cf2e65548e5fa3709ca9df032b3c8516711f2158603dda7569802e66494 SHA512 432b9a12f046b4fdf819b3e187f725c6ef2531570f2b5cb6f197ea95ac6edbd440a3a1d8b0af753bf50d4667cebfb87463abe6f5504f2aeb85a7d3933299eb87
MISC metadata.xml 400 BLAKE2B b244ebd9f79b1c3313797b0384339d17df61913473cd26ab01c8490fe02cbe735609dbd2b2d76e7b1b7f716bbb3038590517481a05c1b7886ad49905f171f5e3 SHA512 3cb1600426cdc5b9ec3bd5d18b547dedb961bbc341891293f828e70d5156d845c8676ba25244804d32c702fab40134c39237e5ce4fc518104a969a8f8ffb282f
diff --git a/dev-python/httpx-socks/httpx-socks-0.7.8.ebuild b/dev-python/httpx-socks/httpx-socks-0.7.8.ebuild
new file mode 100644
index 000000000000..6a6762974b59
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.7.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/httpx-0.26.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ <dev-python/httpcore-0.19.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest