summaryrefslogtreecommitdiff
path: root/dev-python/httpx-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-11 23:35:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-11 23:35:14 +0000
commita3c403d854118e8ef0e2d661383445eb2d7ec732 (patch)
tree4c0b622f99f30d948fa1dada7cf6be2c0baaa8ac /dev-python/httpx-socks
parent20ba650e8d3869757f6c89b23f8b41500cd64657 (diff)
gentoo auto-resync : 11:02:2024 - 23:35:13
Diffstat (limited to 'dev-python/httpx-socks')
-rw-r--r--dev-python/httpx-socks/Manifest2
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.8.1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index e5a701ec53b2..6e7de9cc6298 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1,3 +1,5 @@
DIST httpx-socks-0.8.0.gh.tar.gz 15285 BLAKE2B 1da3bffff2be273e62452d96c8e07f38cf3c488bb89704ab377565feecafc1f96e9b96b615dfca4c3721c295414005014f868982a440ed47f3454814545aa6c7 SHA512 f58555670bc689002633daf3cf373641cbab6417636d16e878d5f9fc796b8bf7111d7c6985909590ccaeedb95793f589676e7f36c217330cbf46b4778319a4b7
+DIST httpx-socks-0.8.1.gh.tar.gz 15289 BLAKE2B 08a8431c5818ea653ea27a0dbc3de6708cb81a7129cda779e8c8cbe3d497ccdad0ed646faf06c5138f6c136a74d4c1b06e6e3920fc5362d471aa03372721cd33 SHA512 804e609826eff4c9e321440b657f3c96d688bf27a4e9a1fdd6b07a410f7f7671fef840403d2231a48b53133a8a4db9522f6c46467e78dc2443270fea4116d66e
EBUILD httpx-socks-0.8.0-r1.ebuild 1215 BLAKE2B 161026c144fd49e0b9fe516f3d2dd5177f6f196db3621b4192092f804094045a6c085afe7811b4f25355bfa55c707120f809146afad992d1c1fe529bd83aa253 SHA512 a40399ced8524a28c337af5d1035c256acbd4535988cabb2b69cbc2da10200f23f2d16f36c314f408320aa503df2b1694d6112b2fb2562b0533ec7589cee64cb
+EBUILD httpx-socks-0.8.1.ebuild 1265 BLAKE2B 5dd7bead159ded13898a6bc0717399d1be0a9e302b5fd6861b2be6f4c3c98094de29e658867925bf6d166b9c79a0779b08b737d7e9c9331c01f53abea4845e57 SHA512 d49c268efa0b58abb8465bedbcdca8df38eb1df4cb98c18f4e0faec7faa2607c10515015f58fa759a4d49cd349fdadb3cf7844d695db1348cfb32bc694588402
MISC metadata.xml 400 BLAKE2B b244ebd9f79b1c3313797b0384339d17df61913473cd26ab01c8490fe02cbe735609dbd2b2d76e7b1b7f716bbb3038590517481a05c1b7886ad49905f171f5e3 SHA512 3cb1600426cdc5b9ec3bd5d18b547dedb961bbc341891293f828e70d5156d845c8676ba25244804d32c702fab40134c39237e5ce4fc518104a969a8f8ffb282f
diff --git a/dev-python/httpx-socks/httpx-socks-0.8.1.ebuild b/dev-python/httpx-socks/httpx-socks-0.8.1.ebuild
new file mode 100644
index 000000000000..04525123e363
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ dev-python/tiny-proxy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' setup.py || die
+
+ distutils-r1_src_prepare
+}