summaryrefslogtreecommitdiff
path: root/dev-python/httpx-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
commit2cd9ff612e84f0c1ef63c9e9e13be53fe576cc2b (patch)
tree6e975e18646dac9f4b55fab980271a027428cc4d /dev-python/httpx-socks
parentabe17cf152eeb7571da8db4b25a30465644a41ba (diff)
gentoo auto-resync : 08:11:2024 - 03:03:27HEADmaster
Diffstat (limited to 'dev-python/httpx-socks')
-rw-r--r--dev-python/httpx-socks/Manifest2
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.9.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index 3c25e2e527a5..5766eda4ca02 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1,3 +1,5 @@
DIST httpx-socks-0.9.1.gh.tar.gz 15210 BLAKE2B 88f38797110227c4e4f01fea7e47c9403573c3c06f6bd644858a6ad4947d90dcbd33c03a0d30a91f227b0e3f341c249dcdef2b009065447e95579e561fee7f4b SHA512 dec2a0eb2dbc692a7e45a2f0df3711057fdc50e7284985d234ed68b3af01372faaa532d070736a005eb49191d55927dc949e9297a6a471b89cf085ef38b56910
+DIST httpx-socks-0.9.2.gh.tar.gz 15445 BLAKE2B 273380fc722780d090039aa74dd646ca3cd5dbc18d5ab3a030847fef0ad515f4ad171289d9cc125d1e8218b8e81a73c1b192caa2708238ed7ac288d3b2419c41 SHA512 41816f9dfa998b8a7e99ddc68d9e3473184fa44ecb08950234759dd9765496e92309852474d8688e392f6a25c4fcbeb7d6358b07bc574c68fd423e05bd052990
EBUILD httpx-socks-0.9.1.ebuild 1359 BLAKE2B d465f84d749549adb3ade1c59c93a9f19ec81cc2f84a4c9ea4bc1d515234902fcaa13b1da2dd5c39845e47a43fa679804b3f48cfb00cabc0caa5fd873f39aa91 SHA512 95359072a21925baf20fe015885463e122ad7f9efe9cf95f8f04398a2f1a9f3c3f4de2c2a271fb643e06f778f6ec720dd9a0a98b80c0e43c231ce01164654a92
+EBUILD httpx-socks-0.9.2.ebuild 1367 BLAKE2B 7bda1b8a316968585d996ba60480444410dbca1dc63c1524b8cbba4e557dcaa1b18bf33f844505674697993dc56a9dbb8d7805345c4d7b6f3c3369ddb0251777 SHA512 f4748bd6415b420a6f008fd6beb8ac89d90f124d10602a2dd6bfd93cca5448dc4f00e58da87256e570c77032d71d55c5bebc85566697ae191e3fa3c90dafcfb2
MISC metadata.xml 400 BLAKE2B b244ebd9f79b1c3313797b0384339d17df61913473cd26ab01c8490fe02cbe735609dbd2b2d76e7b1b7f716bbb3038590517481a05c1b7886ad49905f171f5e3 SHA512 3cb1600426cdc5b9ec3bd5d18b547dedb961bbc341891293f828e70d5156d845c8676ba25244804d32c702fab40134c39237e5ce4fc518104a969a8f8ffb282f
diff --git a/dev-python/httpx-socks/httpx-socks-0.9.2.ebuild b/dev-python/httpx-socks/httpx-socks-0.9.2.ebuild
new file mode 100644
index 000000000000..fcd45387461b
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/async-timeout-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hypercorn-0.14.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' setup.py || die
+
+ distutils-r1_src_prepare
+}